Retornar a última h...
 
Notifications
Clear all

Retornar a última hora da exibição de um evento

7 Posts
5 Usuários
1 Reactions
1,727 Visualizações
(@rodrigocc)
Posts: 5
Active Member
Topic starter
 

Boa Tarde pessoal

 

Tenho uma planilha, na qual tenho que calcular quantas vezes um evento foi exibido. Minha dúvida é que agora tem que ser implementada a função para exibir além da contagem, qual foi o horário da última exibição. Não faço ideia de que formula utilizar para essa função. Estou enviando uma planilha modelo em anexo, vejam que CM882210 se repete várias vezes na coluna B, porém na coluna C ele tem vários horários diferentes, na coluna é gostaria de retornar sempre o horário da última exibição.

 

Desde já agradeço a ajuda

 

 

Atenciosamente

 

Rodrigo

 
Postado : 27/01/2024 2:28 pm
(@rodrigocc)
Posts: 5
Active Member
Topic starter
 

Faltou a Planilha

 
Postado : 27/01/2024 2:30 pm
(@rodrigocc)
Posts: 5
Active Member
Topic starter
 

Não estou conseguindo anexar a planilha segue o modelo:

 

    Número de Exibições H. Última Exibição
CM882210 08:25:20 16  
CM882210 09:25:20    
CM882210 10:25:20    
CM882210 11:25:20    
CM882210 12:25:20    
CM882210 13:25:20    
CM882210 14:25:20    
CM882210 15:25:20    
CM882210 16:25:20    
CM882210 17:25:20    
CM882210 18:25:20    
CM882210 19:25:20    
CM882210 20:25:20    
CM882210 21:25:20    
CM882210 22:25:20    
CM882210 23:25:20    
 
Postado : 27/01/2024 2:32 pm
(@osvaldomp)
Posts: 852
Prominent Member
 

Olá, @rodrigocc.

As fórmulas abaixo retornam o que você pediu se aplicadas na planilha com o modelo de dados que você postou.

 

número de exibições

=CONT.VALORES(B:B)

 

último horário

=PROC(2; 1/(C:C>0); C:C)

Osvaldo

 
Postado : 27/01/2024 2:57 pm
(@rodrigocc)
Posts: 5
Active Member
Topic starter
 

Boa tarde Osvaldo

 

Agradeço pelo rápida resposta, no modelo postado eu fiz uma limpeza das linhas, por exemplo essa planilha vai ter outros valores, teria que retornar o valor da última exibição sempre que o valor de B:B for =CM882210, ai puxar a última exibição. 

 
Postado : 27/01/2024 3:15 pm
(@rodrigocc)
Posts: 5
Active Member
Topic starter
 

Boa Tarde Osvaldo

 

Fiz um teste usando como base a sua formula, só incluindo o critério de B:B, ficou conforme abaixo:

 

=PROC(2; 1/(B:B="CM882210"); C:C)

 

Deu certo, muito obrigado pela ajuda

 

 

Atenciosamente

 

Rodrigo

 
Postado : 27/01/2024 3:33 pm
Osvaldomp reacted
(@osvaldomp)
Posts: 852
Prominent Member
 

Coloque o valor a ser buscado em D1.

 

=CONT.SE(B:B;D1)

 

Esta abaixo é matricial, portanto, em versões anteriores a XL2019, após colar a fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter

=MÁXIMO(SE(B:B=D1;C:C))

obs. eu coloquei as referências às colunas inteiras, mas é conveniente colocar somente o intervalo que contenha dados .

Osvaldo

 
Postado : 27/01/2024 3:46 pm
(@westgangster12)
Posts: 1
New Member
 

Para obter o horário da última exibição de um evento específico na sua planilha, você pode usar a função PROCV em conjunto com a função SE para verificar se o evento da linha atual é o mesmo que o evento que você está buscando e, se for, retornar o horário correspondente. Aqui está um exemplo de como você pode fazer isso:

=SE(A2="CM882210"; ÚLTIMOEXIBIDO; "")

Neste exemplo, A2 é onde está o evento que você quer buscar (CM882210), e ÚLTIMOEXIBIDO é a referência para o horário da última exibição, que você precisa definir como a célula onde está o horário da última exibição para o evento CM882210. Certifique-se de ajustar as referências de célula conforme necessário para a sua planilha.

 
Postado : 23/03/2024 9:44 am
(@blazebolt12)
Posts: 1
New Member
 

Você pode usar a função PROCV para encontrar a última ocorrência de um evento e retornar seu horário correspondente. Por exemplo, na célula D2, você pode usar a fórmula =PROCV(B2;B:C;2;FALSO) para encontrar o horário da última exibição do evento em B2. Certifique-se de ordenar os dados por ordem crescente na coluna B para que o PROCV funcione corretamente. Se precisar de mais ajuda com a fórmula, fique à vontade para perguntar!

 
Postado : 28/03/2024 6:25 am
(@steelheart8)
Posts: 1
New Member
 

Para calcular o horário da última exibição de um evento específico na sua planilha, você pode usar a função PROCV em conjunto com a função CORRESP para encontrar a última ocorrência do evento e retornar o horário correspondente. Aqui está um exemplo de fórmula que você pode utilizar:

=ÍNDICE(C:C, CORRESP(2;1/(B:B="CM882210");LIN(B:B)))

Nesta fórmula, assumimos que os eventos estão na coluna B e os horários correspondentes estão na coluna C. Substitua "CM882210" pelo evento que você deseja buscar. Essa fórmula retornará o horário da última exibição desse evento. Lembre-se de adaptar as referências de coluna e linha de acordo com a estrutura da sua planilha.

 
Postado : 01/04/2024 2:11 pm