Notifications
Clear all

Numero maximo

19 Posts
3 Usuários
0 Likes
792 Visualizações
(@trindade97)
Posts: 9
Active Member
Topic starter
 

Bom dia! preciso de ajuda para o arquivo em anexo. A tabela regista a data/hora de  saída e entrada de viaturas. o objectivo é encontrar numa coluna o numero maximo de viaturas que se encontram em simultaneo fora

 

 
Postado : 23/11/2023 11:08 am
(@trindade97)
Posts: 9
Active Member
Topic starter
 

Desde ja agradeço a ajuda de facto ñ tem sido facil transmitir a mensagem, deixo o quadro para analisar entre o resultado da formula e a realidade

Viatura hora saida hora entrada Resultado da sua formula N.º Viaturas fora (real)
Viatura A 01/01/2023 10:00 01/01/2023 20:20 15 5 Na realidade encontra-se fora a viatura A, B, C, F e D
Viatura B 01/01/2023 10:05 01/01/2023 10:45 5 5  A,B,C,F e D      
Viatura C 01/01/2023 10:10 01/01/2023 10:45 5 5  A,B,C,F e D      
Viatura F 01/01/2023 10:30 01/01/2023 11:00 6 5  A,B,C,F e D      
Viatura D 01/01/2023 10:35 01/01/2023 11:25 7 6 A B C F D e E      
Viatura E 01/01/2023 10:45 01/01/2023 13:00 7 7 A  F D E B C F       
Viatura B 01/01/2023 11:00 01/01/2023 11:30 4 3          
Viatura C 01/01/2023 12:00 01/01/2023 14:00 6 3          
Viatura F 01/01/2023 12:30 01/01/2023 14:00 6 3          
Viatura D 01/01/2023 13:00 01/01/2023 13:10 4 4          
Viatura E 01/01/2023 13:30 01/01/2023 15:00 4 3          
Viatura F 01/01/2023 15:00 01/01/2023 18:00 5            
Viatura B 01/01/2023 15:50 01/01/2023 16:00 3             
Viatura C 01/01/2023 17:00 01/01/2023 17:15 3            
Viatura D 01/01/2023 17:30 01/01/2023 18:00 3            
Viatura A 01/01/2023 21:05 01/01/2023 22:10 1            
 
Postado : 07/12/2023 11:53 am
(@osvaldomp)
Posts: 852
Prominent Member
 

Me parece que com os seus últimos exemplos eu consegui entender com mais exatidão.

"Na realidade encontra-se fora a viatura A, B, C, F e D" ~~~> a viatura E, linha 7, não se inclui nesse critério?

Qual é a versão do seu Excel ?

Osvaldo

 
Postado : 07/12/2023 3:01 pm
(@trindade97)
Posts: 9
Active Member
Topic starter
 

@osvaldomp Bom dia, Viatura E linha 7, na realidade são 6 viaturas fora, por engano inseri duas vezes a viatura F. Versão do excel: Professional Plus 2013

 
Postado : 12/12/2023 8:03 am
(@osvaldomp)
Posts: 852
Prominent Member
 

Experimente:

EDIT: a fórmula abaixo é matricial e por isso deve ser inserida com Ctrl+Shift+Enter se a versão do Excel for anterior a 2019.

Para inserir como matricial cole a fórmula na célula, aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter.

=SOMA((FREQÜÊNCIA(SEERRO(CORRESP(SE((A2<>$A$2:$A$17)*(B2<$C$2:$C$17)*(C2>$B$2:$B$17);$A$2:$A$17;"");$A$2:$A$17;0);"");SEERRO(CORRESP(SE((A2<>$A$2:$A$17)*(B2<$C$2:$C$17)*(C2>$B$2:$B$17);$A$2:$A$17;"");$A$2:$A$17;0);""))>0)*1)+1

Osvaldo

 
Postado : 14/12/2023 5:34 pm
Página 2 / 2