Notifications
Clear all

[Resolvido] SOMA VINCULADA A 03 DIFERENTES CONDIÇÕES (PARÂMETROS)

7 Posts
3 Usuários
0 Likes
988 Visualizações
(@asampaio)
Posts: 24
Eminent Member
Topic starter
 

Olá, pessoal

Preciso de ajuda para saber qual é a fórmula necessária na célula C12 para que ao alterarmos manualmente os parâmetros das células C9 (Parâmetro 1), C10 (Parâmetro 2) e C11 (Parâmetro 3), a fórmula da célula C12 veja a tabela C2:O7 e calcule o resultado, conforme exemplo em anexo.

Muito obrigado,
Albert

 
Postado : 07/10/2022 1:14 pm
daphne
(@daphne)
Posts: 95
Estimable Member
 

A função SOMARPRODUTO vai atender sua necessidade:

 

=SOMARPRODUTO(($D$4:$O$7) * ($D$2:$O$2=C9) * ($D$3:$O$3=C10) * ($C$4:$C$7=C11))

 

 
Postado : 07/10/2022 8:52 pm
(@asampaio)
Posts: 24
Eminent Member
Topic starter
 

@daphne Muito obrigado! Funcionou e ajudou bastante.

 
Postado : 09/10/2022 1:04 pm
JSCOPA10
(@jscopa10)
Posts: 341
Reputable Member
 

@asampaio, sempre que seu tópico for atendido, marque ele como "resolvido"!! ... Assim ele fica verde!! ... Este vou marcar para você!!!

 
Postado : 10/10/2022 8:44 pm
(@asampaio)
Posts: 24
Eminent Member
Topic starter
 

@jscopa10 Combinado

 
Postado : 11/10/2022 11:17 pm
(@asampaio)
Posts: 24
Eminent Member
Topic starter
 

@daphne oi, @daphne. Como disse antes, a função funcionou. Porem como a planilha e o intervalo da soma é grande, a planilha fica travando e demorando alguns segundos para calcular (chegando a usar os 08 threads do meu processador(. Haveria alguma solucao para isso?

 
Postado : 11/10/2022 11:21 pm
(@asampaio)
Posts: 24
Eminent Member
Topic starter
 

Olá,
Depois de pesquisar bastante, consegui resolver, graças a Deus. Solução anexada.

Primeiro eu criei as fórmulas de concatenação na coluna A. Depois eu, desenvolvi a formula abaixo para o campo amarelo:

=SEERRO(SOMA(($A$5:$A$20=$I5&$J5)*(DESLOC($D$5:$G$20;0;CORRESP(K$4;$D$4:$G$4;0)-1;;1)));"")

Funcionou!

Achei a solução neste site: http://www.linhadecodigo.com.br/artigo/781/excel-formulas-matriciais.aspx

Abcs a todos que de alguma forma se interessaram no assunto.

Atenciosamente,
Albert Sampaio

 
Postado : 29/10/2022 2:19 pm