Notifications
Clear all

[Resolvido] somarproduto somases com erro


pedrobb
Posts: 25
Registered
Topic starter
(@pedrobb)
Eminent Member
Entrou: 3 anos atrás

=SOMARPRODUTO((MÊS($A$6$P$1000))

=SOMASES($P$6$A$913;"<="&FIMMÊS($T$6;0))

Na Planilha anexa a fórmulas acima estão com erro.

Preciso somar os valores da colunas P, se Mês/Ano da Coluna A forem Iguais, com retorno nas Coluna X e/ou Y.

No meu entendimento, somarproduto ou somases dá o resultado. Tentei com as 2 funções e não consegui. Onde estão os erros?

Responder
6 Respostas
Estevaoba
Posts: 481
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

=SOMARPRODUTO( $P$6:$P$1000;( MÊS( $A$6:$A$1000)=MÊS( T6))*( ANO( $A$6:$A$1000)= ANO( T6))*( $P$6:$P$1000<>"") )

Good luck

Responder
4 Respostas
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 25

@estevaoba Funcionou muito bem. Obrigado!!!!!  Valeu!!!

Pra aprendizado, vou esperar se há fórmula também com Somases.

Responder
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 25

@estevaoba 

Percebi que não posso Somar as taxas (Intervalo P6:P1000). Preciso extrair a Média Simples deste Intervalo conforme o Mês e Ano. Você sabe a alternativa?

Responder
Estevaoba
Registered
(@estevaoba)
Entrou: 5 anos atrás

Reputable Member
Posts: 481

@pedrobb Tente esta fórmula matricial. Depois de colar, confirme com Ctrl+Shift+Enter em vez de apenas Enter.

=MÉDIA( SE( MÊS( $A$6:$A$1000)=MÊS( T6); SE( ANO( $A$6:$A$1000)= ANO( T6); SE(  $P$6:$P$1000 <>""; $P$6:$P$1000 ) ) ))

Ab.

Responder
pedrobb
Registered
(@pedrobb)
Entrou: 3 anos atrás

Eminent Member
Posts: 25

@estevaoba É isso mesmo. Obrigado!!!!!!!!!

Responder
Estevaoba
Posts: 481
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

De nada, amigo. Que bom que deu certo.

Tenha um dia abençoado.

Responder