Notifications
Clear all

[Resolvido] Sequencia trocada ate certo numero


jau288
Posts: 51
Registered
Topic starter
(@jau288)
Trusted Member
Entrou: 6 anos atrás

Ola, colegas estou com um problema:  Na planilha tenho 1 a 15 - sendo a contagem antes e depois - o problema e quando chega em 15 - teria que fica 14-15-1 e não 14-15-16 e também NÃO O-1-2 e sim 1-2-3 ..coloquei uma plan em anexo p entenderem melhor.. obrigado pela atenção... 

Responder
4 Respostas
EdsonBR
Posts: 858
Moderator
(@edsonbr)
Prominent Member
Entrou: 6 anos atrás

Olá, @jau288

 

Para o primeiro problema, vc poderia explorar a função MOD. As fórmulas poderiam ficar assim:

Na I4: =MOD($F$3-2;15)+1 , na I5: =MOD($F$3-1;15)+1 e na I6: =MOD($F$3;15)+1

Não entendi o que vc precisa no segundo problema. É a mesma lógica? Dê alguns exemplos de valores pra ilustrar...

 

Responder
jau288
Posts: 51
Registered
Topic starter
(@jau288)
Trusted Member
Entrou: 6 anos atrás

Ola Edson...ficou certinho . So que agora se coloco por ex 1 na f3 - fica = 15 - 1 - 3  e teria que ficar 1 - 2 - 3 ...entendeu?

Responder
Estevaoba
Posts: 448
Registered
(@estevaoba)
Reputable Member
Entrou: 4 anos atrás

Em i4 e copiar até k4:

=SE($F$3=1;COL(A1);MOD($F$3+COL(A1)-3;15)+1)

Responder
jau288
Posts: 51
Registered
Topic starter
(@jau288)
Trusted Member
Entrou: 6 anos atrás

Ola estevaoba, Certinho... muito obrigado ...

Responder