Notifications
Clear all

[Resolvido] Procv com vários resultados possíveis sem retorno de duplicados


llrodrigo
(@llrodrigo)
Estimable Member Registered
Entrou: 5 anos atrás
Posts: 151
Topic starter  

Bom dia

Tenho uma planilha onde procuro uma "Chave" e preciso de retorno todos os resultados possíveis, mas sem que venham duplicados.

Por exemplo, se tenho 3 vezes o valor "10:00" e 3 vezes o valor "11:00" para esta chave, o retorno deveria ser:

10:00

11:00

Estou anexando um exemplo do que tentei até o momento sem sucesso

Obs. o que tentei parece ficar bem "pesado para processar"

 

 


ResponderCitar (Quote)
Tags do Tópico
deciog
(@deciog)
Prominent Member Registered
Entrou: 5 anos atrás
Posts: 828
 

@llrodrigo, Boa Tarde

Para a versão Excel antes de 2019, feche com CTRL + SHIFT + ENTER, são formula matricial

Usa esta formula na célula A10

=SEERRO(ÍNDICE(dados!$B$2:$B$16690;CORRESP(0;CONT.SE($A$9:$A9;dados!$B$2:$B$16690)+(dados!$A$2:$A$16690=$AI$2);0);COL(A1));"")

Confere se é desta forma que desejas

Se foi útil, clique na mãozinha Curtir é a forma de agradecimento

Decio

 

 

Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Paulo - SP
Décio Gassi


llrodrigo curtiu
ResponderCitar (Quote)
llrodrigo
(@llrodrigo)
Estimable Member Registered
Entrou: 5 anos atrás
Posts: 151
Topic starter  

@deciog Obrigado.

Porém está retornando valores a mais. Usando o "remover duplicatas do Excel" (para conferir) restam 27 valores.

Mas está retornando mais. Somente alterei uma coisa, onde está:

"$AI$2"

é na verdade

$AJ$2.

Outra coisa, para que não tenha que aumentar manualmente o intervalo (neste exemplo são 16690 linhas), como pode ser feito?


ResponderCitar (Quote)
Estevaoba
(@estevaoba)
Reputable Member Registered
Entrou: 4 anos atrás
Posts: 438
 

@llrodrigo, experimente esta fórmula matricial em A10 e copie para preencher a coluna.

Good luck!

=SEERRO(ÍNDICE(dados!$B$2:$B$100000;CORRESP(1;(CONT.SE(A$9:A9;dados!$B$2:$B$100000)=0)*(dados!$B$2:$B$100000<>"")*(dados!$A$2:$A$100000=$AJ$2);0));"")

llrodrigo curtiu
ResponderCitar (Quote)
llrodrigo
(@llrodrigo)
Estimable Member Registered
Entrou: 5 anos atrás
Posts: 151
Topic starter  

@estevaoba Bom dia, Deu certo de acordo com o desejado.

Vou possivelmente fazer outras "implementações" nesta mesma planilha. O melhor ou correto é abrir novas questões, ou fazer adendos nesta mesma questão?


ResponderCitar (Quote)
EdsonBR
(@edsonbr)
Prominent Member Moderator
Entrou: 5 anos atrás
Posts: 750
 
Postado por: @llrodrigo

O melhor ou correto é abrir novas questões, ou fazer adendos nesta mesma questão?

Dúvidas não relacionadas ao título do tópico favor criar novo tópico. Obrigado.


llrodrigo curtiu
ResponderCitar (Quote)