Notifications
Clear all

Procurar em mais de uma linha e trazer o resultado correspondente

Página 1 / 2

GabrielStabile
Posts: 3
Registered
Topic starter
(@gabrielstabile)
New Member
Entrou: 3 meses atrás

Pessoal poderiam me ajudar por favor?

No MS Excel, preciso de uma formula que busque numa matriz (quadrado entre linhas e colunas) e que me traga o valor de uma linha se encontrar.

exemplo: Procurar b111a0ba na matriz A1:c13 e se encontrar traz o resultado da linha 15

  a b c
1 b111a0aa b111a0a9 b111a008
2 b111a0ab b111a0b0 b111a009
3 b111a0a4 b111a0b1 b111a010
4 b111a0a5 b111a0ba b111a017
5 b111a0a6 b111a0bb b111a018
6 b111a0a7 b111a0b4 b111a019
7 b111a0b5 b111a0b8  
8 b111a0b6 b111a0b9  
9 b111a0b7 b111a040  
10 b111a058 b111a060  
11 b111a061 b111a057  
12 b111a064    
13 b111a067    
14      
15 Resultado D Resultado E Resultado F

Obrigado!

 

Responder
Tags do Tópico
9 Respostas
1 Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@gabrielstabile, pelo que entendi parece fácil, mas posta um arquivo com esse exemplo, assim temos como testar uma solução!!! .... Explique no próprio arquivo o que deseja, e faça um exemplo na mão!!!

Responder
Estevaoba
Posts: 472
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás
=ÍNDICE(A15C15))))

Fórmula matricial. Se seu Excel for anterior ao 365, cole e confirme com Ctrl+Shift+Enter em vez de apenas Enter:

Good luck!

Responder
1 Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@estevaoba, descobri que para a fórmula aparecer inteira aqui tem que colocar um espaço ou asterisco entre os blocos ... veja ... índice(a:a; Corresp(x;b:b;0))

Responder
GabrielStabile
Posts: 3
Registered
Topic starter
(@gabrielstabile)
New Member
Entrou: 3 meses atrás

@jscopa10 e @estevaoba, bom dia!

segue arquivo com minha necessidade. Obrigado!

Responder
1 Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320
GabrielStabile
Posts: 3
Registered
Topic starter
(@gabrielstabile)
New Member
Entrou: 3 meses atrás

@jscopa10 e @estevaoba,

maravilha. Muito obrigado pela ajuda de vocês.

 

Responder
Estevaoba
Posts: 472
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Obrigado, @JSCOPA10.

Vou testar aqui:

=ÍNDICE(A15: C15; MÍNIMO( SE( A1: C13= E1; COL( A15: C15))))

Responder
1 Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@estevaoba, não precisa de tanto espaço k .... pelo que testei, bastaria um espaço entre a ÌNDICE e a MÌNIMO, como fiz no meu exemplo ali acima !!

Responder
Página 1 / 2