Notifications
Clear all

[Resolvido] Pesquisar palavras em célula a partir de lista


Mineiro
Posts: 107
Registered
Topic starter
(@mineiro)
Estimable Member
Entrou: 7 anos atrás

Colegas, boa tarde!

Uma coluna possui diversas células preenchidas com diversas informações.

Possuo uma lista de palavras que preciso verificar se fazem parte ou não dessas células. 

As palavras que fazem parte da lista podem ocupar qualquer posição dentro da frase.

Por fim, preciso que seja apontada em que linha a palavra encontrada está.

Agradeço a ajuda.

Segue planilha com o exemplo.

 

Responder
2 Respostas
2 Respostas
EdsonBR
Moderator
(@edsonbr)
Entrou: 6 anos atrás

Prominent Member
Posts: 865

@mineiro, boa tarde

Fórmula na célula E2:

=SE(CONT.SE($A$2:$A$12;"*"&C2&"*")>0;"Sim";"Não")

Fórmulas nas células F2 e G2 respectivamente (matriciais => CTRL SHIFT ENTER):

=SEERRO("linha " & MENOR(SE(ÉNÚM(LOCALIZAR(C2;$A$2$A$12);"");1);"-")
=SEERRO("linha " & MENOR(SE(ÉNÚM(LOCALIZAR(C2;$A$2$A$12);"");2);"-")
Responder
Mineiro
Registered
(@mineiro)
Entrou: 7 anos atrás

Estimable Member
Posts: 107

Edson, boa noite!

Muito obrigado pela ajuda. Funcionou muito bem!

Abraço

Responder