Notifications
Clear all

Ordenar resultados com ÍNDICE CORRESP


llrodrigo
(@llrodrigo)
Estimable Member Registered
Entrou: 5 anos atrás
Posts: 151
Topic starter  

Boa tarde

Em outro tópico, consegui obter o retorno de uma tabela com valores exclusivos. Precisava agora que estes valores viessem ordenados, do menor para o maior. Estou anexando um exemplo.(Não quero ordenar depois dos resultados já trazidos para não perder a "ordem" das fórmulas nos cálculos).


ResponderCitar (Quote)
Estevaoba
(@estevaoba)
Reputable Member Registered
Entrou: 4 anos atrás
Posts: 438
 

Pode ser feito usando uma coluna auxiliar, por exemplo coluna E na aba dados, com a primeira fórmula matricial abaixo em E2 e copiando para baixo.

Em seguida, a outra fórmula, também matricial em AJ2 da plan5 e copiar para baixo.

Good luck!

=SEERRO(MENOR(SE($A$2:$A$808=Plan5!$AJ$1;$B$2:$B$808+0);LIN(Z1));"")

=SEERRO(ÍNDICE(dados!$E$2:$E$808;CORRESP(1;(CONT.SE(AJ$1:AJ1;dados!$E$2:$E$808)=0)*(dados!$E$2:$E$808<>"");0));"")

 


llrodrigo curtiu
ResponderCitar (Quote)