Função CONT.SE + Ad...
 
Notifications
Clear all

Função CONT.SE + Adicionar nova linha à Tabela = Erro de Referência Relativa


mfrenkiel
Posts: 4
Registered
Topic starter
(@mfrenkiel)
New Member
Entrou: 3 meses atrás

Boa noite! Tudo bem?

Procurei por algum post com erro parecido, porém não encontrei nada similar, espero que possam me ajudar. 

Estou criando uma tabela para o controle de Ativos Financeiros e, como não entendo de VBA, estive quebrando a cabeça para criar um jeito de atualizar o Preço Médio de ativos apenas com fórmulas. 

Bom... quando finalmente consegui ajustar uma fórmula através de CONCATENAR e CONT.SE, notei que, ao adicionar novas linhas na minha tabela, a referência da contagem (coluna H) estava se alterando sozinha, o que ocasiona uma repetição errada na contagem (a exemplo das linhas 09 e 10 que deveriam ter contagens diferentes). 

Estou deixando o .rar da planilha de exemplo anexada para a referência e agradeço desde já!

 

 

Responder
7 Respostas
2 Respostas
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@mfrenkiel, Até a G7 a fórmula está correta, a partir de G8 está errada .......... arrasta a fórmula de G7 até o final e a contagem ficará certa!!!

Responder
mfrenkiel
Registered
(@mfrenkiel)
Entrou: 3 meses atrás

New Member
Posts: 4

@jscopa10 Olá, tudo bem?! De fato a fórmula fica correta até a penúltima linha, mas o problema é, justamente, que quando se cria uma nova linha a fórmula se altera (apenas na última e penúltima linhas) sem eu pedir. Esse é o problema que não consigo resolver.

Funciona se eu ficar arrastando manualmente a fórmula toda vez que criar uma linha, mas gostaria de saber se há algum jeito de resolver isso.

Obrigado!

Responder
Estevaoba
Posts: 472
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Em G2:

=SOMASES($D$2:[@[Qtde.]]; $C$2:[@Fundo];[@Fundo])

 

Good luck!

Responder
2 Respostas
mfrenkiel
Registered
(@mfrenkiel)
Entrou: 3 meses atrás

New Member
Posts: 4

@estevaoba Olá, amigo! Bom dia! Tudo bem?!

Infelizmente o ajuste na coluna G não funcionou... ao adicionar novas linhas, a coluna H ainda "buga" e ajusta sua fórmula. Espero que tenha algo mais que possa fazer, senão vou no modo manual mesmo...

Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@mfrenkiel , se você insere linhas vai ter sempre que arrastar as fórmulas!! ... Só não é necessário arrastar as fórmulas quando você digita dados na última linha vazia, neste caso a formula se ajusta!!!

Se a última sugestão do Estevaoba não funcionar, veja se esta funciona !!!

 

Responder
Estevaoba
Posts: 472
Registered
(@estevaoba)
Reputable Member
Entrou: 5 anos atrás

Bom dia.

A mesma alteração vale para a coluna H:

=CONT.SES($C$2: [@Fundo];[@Fundo])

Ab.

Responder
1 Responder
mfrenkiel
Registered
(@mfrenkiel)
Entrou: 3 meses atrás

New Member
Posts: 4

@estevaoba @jscopa10  Com esse último ajuste ficou perfeito! Muito obrigado pela ajuda!

Responder