Notifications
Clear all

Formula SE com mais de duas variáveis.


_guedes
Posts: 11
Registered
Topic starter
(@_guedes)
Active Member
Entrou: 7 anos atrás

Bom dia,

Preciso de uma ajuda.

Tenho que fazer a análise de uma planilha de preço onde estou usando a formula SE, porem usava apenas com duas variáveis, e no momento quero usar mais de uma e retornar o resultado com base em uma coluna principal. No anexo eu explico melhor.

Eu utilizo a formula =SE(B2<C2;menorpreço), porém gostaria que ele avaliasse os quatro concorrentes juntos + o local e voltasse qual é o menor entre eles, e se o valor for igual também retorna como menor preço o local, ou seja a base é o local.

Responder
2 Respostas
Fernando Fernandes
Posts: 43842
Registered
(@fernandofernandes)
Illustrious Member
Entrou: 13 anos atrás

Bom dia!!

Tente

=SE(MÍNIMO(B2:F2)=B2;B$1;SE(MÍNIMO(B2:F2)=C2;C$1;SE(MÍNIMO(B2:F2)=D2;D$1;SE(MÍNIMO(B2:F2)=E2;$E$1;$F$1))))

Neste caso está comparando apenas produto por produto!

Att

Responder
Issamu
Posts: 605
Registered
(@issamu)
Honorable Member
Entrou: 7 anos atrás

Outra opção de fórmula é:

=ÍNDICE($B$1:$F$1;CORRESP(MÍNIMO(B2:F2);B2:F2;0))

E também sugiro adicionar a informação para indicar quando houverem mais de um lugar com mesmo preço menor.

=ÍNDICE($B$1:$F$1;CORRESP(MÍNIMO(B2:F2);B2:F2;0))&SE(CONT.SE(B2:F2;MÍNIMO(B2:F2))>1;" + "&CONT.SE(B2:F2;MÍNIMO(B2:F2))-1&" Concorrente(s).";"")

Uma sugestão também é aplicar formatação condicional para destacar os valores menores em cada linha. Para isso selecione todo intervalo de valores da tabela a partir da célula B2 e aplique uma formatação condicional com a fórmula: =B2=MÍNIMO($B2:$F2)

Veja o modelo.

Responder