Notifications
Clear all

Buscar valores de uma base de dados


joaorlneto
(@joaorlneto)
Eminent Member Registered
Entrou: 4 anos atrás
Posts: 37
Topic starter  

Preciso trazer o valor de uma base de dados referenciando 3 informações (Data, origem e destino). 
Porem na tabela base, eu tenho datas diferentes para informações de origem e destino iguais, alterando somente o preço de referencia do período. 

Na tabela onde quero levar os dados, eu preciso trazer os valores por período. 

Segue o anexo para melhor entender, e caso nao fique claro eu posso dar mais explicações. 

João Neto


ResponderCitar (Quote)
joaorlneto
(@joaorlneto)
Eminent Member Registered
Entrou: 4 anos atrás
Posts: 37
Topic starter  

Ninguém deu conta 🙁

João Neto


ResponderCitar (Quote)
Eron
 Eron
(@eron)
Illustrious Member Admin
Entrou: 13 anos atrás
Posts: 102
 

@joaorlneto Calma João, logo o pessoal responde. 

Eron
CRA/RS 27.563
Administrador Fórum Planilhando


ResponderCitar (Quote)
JSCOPA10
(@jscopa10)
Estimable Member Moderator
Entrou: 2 anos atrás
Posts: 206
 

@joaorlneto, gastei 1h na sua dúvida - aparentemente simples - mas não achei uma solução!!! ... Mas aguarde os CARAS BONS!! kk


ResponderCitar (Quote)
JSCOPA10
(@jscopa10)
Estimable Member Moderator
Entrou: 2 anos atrás
Posts: 206
 

@joaorlneto, meu amigo Bernardo Maia deu uma solução, testa aí .... É matricial, finaliza com Crtl+Shift+Enter

 

=ÍNDICE($D$2:$D$19;MÁXIMO(SE(($B$2:$B$19&$C$2:$C$19=I2&J2)*($A$2:$A$19<=H2);LIN($D$2:$D$19)-1))) 

 

====

PS: ERON, o Bernardo Maia disse que já tentou umas 3x criar nova conta, mas não consegue!!!!!!!!!!!!!!!!

Este post foi modificado 3 semanas atrás por JSCOPA10

deciog e Bernardo curtiram
ResponderCitar (Quote)