Notifications
Clear all

Filtro excel


souzadenilson
Posts: 72
Registered
Topic starter
(@souzadenilson)
Trusted Member
Entrou: 9 anos atrás
  1. Bom dia. Como faço para ao selecionar um produto no excel ele apareça em outra celula do excel, porem tem como especificar o início e a ultima linha ficaria sem valor fixo. Achei na internet usando as funções indice, corresp, desloc, mas ela especificou o intervalo (c6:c12), tem como deixar desde jeito (c6:c)
Responder
6 Respostas
Estevaoba
Posts: 448
Registered
(@estevaoba)
Reputable Member
Entrou: 4 anos atrás

Talvez com a função INDIRETO, usando uma outra célula, A1 por exemplo, para informar a linha final do intervalo.

Seria algo como:

=INDIRETO("Plan1!C6:C"&A1)

 

Good luck!

Responder
souzadenilson
Posts: 72
Registered
Topic starter
(@souzadenilson)
Trusted Member
Entrou: 9 anos atrás

Nao funcionou

Responder
JSCOPA10
Posts: 227
Moderator
(@jscopa10)
Estimable Member
Entrou: 2 anos atrás

souzadenilson, posta um arquivo exemplo, assim a resposta sai de primeira!!!!!!!!!!!!!!!!!!

Responder
3 Respostas
souzadenilson
Registered
(@souzadenilson)
Entrou: 9 anos atrás

Trusted Member
Posts: 72

Ao selecionar um item da coluna "C" ele o nome dele aparece na mesclagem "C3:F3".

Tentei de algumas formas com que esta formula funcionasse somente especificando a 1ª linha e fosse até o infinito, mas está dando erro. Nas linhas que estão mescladas deverá aparecer o nome do produto, já na "A3:B3", o código do produto e na "G3:H3" o saldo.

Esta planilha utilizarei somente o filtro qdo houver necessidade de imprimir as informações de um determinado produto.

Agradeço a cooperação de todos que sempre ajudam na resolução dos tópicos

Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Estimable Member
Posts: 227

@souzadenilson, abri o arquivo e li sua explicação umas 4x ... mas não entendi o que vc quer!!! ... Como outros também podem não entender, dê uns exemplos bem passo a passo !!! ... Pode até escrever o que deseja no próprio arquivo, depois reposta!!!!!!!

 

PS: uma dica ... quando vc usa coluna inteira como nessa fórmula "=SEERRO(PROCV(B6;Cadastros!A:B;2;FALSO);"")" você está dando um trabalho desnecessário ao Excel, afinal ele tem que pesquisar mais de 1 milhão de linhas, sendo que vc só tem 1324 no Cadastro!! ... Nesse caso dê uma boa margem mas limite a formula assim ...  =SEERRO(PROCV(B6;Cadastros!$A$1:$B$5000;2;FALSO);"") !!

 

 

Responder
souzadenilson
Registered
(@souzadenilson)
Entrou: 9 anos atrás

Trusted Member
Posts: 72

@jscopa10 em relacao ao procv nao tive problema, pois itens podem ser acrescido ou excluudo. O que estou tentando adaptar é que ao selecionar um item no filtro o nome do produto aparece na planilha, porem a formula que achei na internet funcionou bem, porem limitou a area que busca informação. Tentei adaptar para fazer a leitura iniciando na c6 e até a coluna com a ultima informação ($C$6:C). A formula esta na coluna j

Responder