Notifications
Clear all

Somar intervalor de tempo função

3 Posts
3 Usuários
0 Reactions
600 Visualizações
 mfl
(@mfl)
Posts: 1
New Member
Topic starter
 

saudações 

 

pessoal vocês podem me ajudar com uma função 

 

preciso de uma função que some a cada 7 dias o valor de uma coluna 

 

por exemplo 

 

A1 50

A2 50

A3 50

A4 50

A5 50 

A6 50

A7 50

 

ai preciso de uma formula que some a cada 7 dias 

 

valendo pix de 5 reais !! uhauha 

 

obrigado 

 

 
Postado : 16/01/2023 11:05 am
daphne
(@daphne)
Posts: 94
Estimable Member
 

@mfl cada célula é um dia??

 
Postado : 16/01/2023 12:27 pm
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

Seguem duas opções de fórmula com intervalos dinâmicos.

A primeira, com a função DESLOC que por ser volátil, pode tornar lento o processamento da sua planilha, dependendo do volume de dados.

A segunda é não volátil.

Cole em B2 e arraste para baixo:

=SE(MOD(LINS(A$1:A1);7)=0;SOMA(DESLOC(A1;-6;0;7;1));"")

=SE(MOD(LINS(A$1:A1);7)=0;SOMA(ÍNDICE($A$1:$A$100;7*QUOCIENTE(LINS(A$1:A1)-1;7)+1):ÍNDICE($A$1:$A$100;7*(QUOCIENTE(LINS(A$1:A1)-1;7)+1)));"")

 

Good luck!

 
Postado : 20/01/2023 7:45 pm