Notifications
Clear all

[Resolvido] Retornar dados com dois criterios  

  RSS

tauron
(@tauron)
Active Member
Entrou: 1 ano atrás
Posts: 13
22/07/2020 9:56 am  

Bom dia, utilizo a formula abaixo para listar dados contidos em outra planilha e funciona perfeitamente. Mas agora há a necessidade de adicionar mais um critério e não estou conseguindo.

=SE($A$4<>"";SEERRO(ÍNDICE(Geral!$A$2:$A$4998;MENOR(SE(Geral!$F$2:$F$4998=$A$4;LIN(Geral!$F$2:$F$4998)-1);LIN($A1));1);"");"")

Além do critério já contido, necessito que seja feita a comparação (Geral!$H$2:$H$4998 = $E$4)

 


ResponderCitar (Quote)
carlosrgs
(@carlosrgs)
Membro Moderator
Entrou: 5 anos atrás
Posts: 611
22/07/2020 12:54 pm  

Boa tarde tauron, poste um arquivo para facilitar no entendimento!

_______________________________________________________________________________________________
Carlos Santos
* Marque o tópico como Resolvido se foi solucionado seu problema.


ResponderCitar (Quote)
tauron
(@tauron)
Active Member
Entrou: 1 ano atrás
Posts: 13
22/07/2020 4:48 pm  

É isso que pretendo.


ResponderCitar (Quote)
tauron
(@tauron)
Active Member
Entrou: 1 ano atrás
Posts: 13
29/07/2020 1:01 pm  

Não consegui da maneira que eu imaginava mas, consegui contornar e obter o resultado pretendido. Agora a questão, ainda relacionada à fórmula, é que estou implementando um formulário para inserir os dados mas, quando os dados são inseridos através do formulário, ele é salvo na planilha "Geral" mas não na planilha "Pericia" e quando é feito diretamente na planilha "Geral", funciona perfeitamente.

caso as planilhas estejam protegidas, a senha é = 1


ResponderCitar (Quote)
Wagner Morel
(@wagner-morel-vidal-nobre)
Illustrious Member
Entrou: 8 anos atrás
Posts: 4052
29/07/2020 3:16 pm  

@tauron,

Boa tarde!

Para salvar na aba Perícia, basta trocar tudo que tiver Plan3 no código do botão Salvar por Plan4.

Se a resposta foi útil para você, por gentileza, Amigo, clique em Curtir.

Atenciosamente
Wagner Morel


ResponderCitar (Quote)
tauron
(@tauron)
Active Member
Entrou: 1 ano atrás
Posts: 13
29/07/2020 4:46 pm  

Boa tarde Wagner!

Não sei se você percebeu que a planilha de "entrada de dados" é a Plan3(Geral), a Plan4(Pericias) é o condensador, ou seja, é na Plan4 que ocorre a separação por dia e turno/periodo, pois a cada ela dinâmica.

Estou postando outra planilha com algumas colunas reexibidas (Geral). Ao informar uma nova data, alguma celula entre P1 e S1 irá alterar e consequentemente na tabela Pericias umas das (A4, A16, A28, A40) e outras funcionalidades em decorrência da inserção de dados (na plan4).

 


ResponderCitar (Quote)
Wagner Morel
(@wagner-morel-vidal-nobre)
Illustrious Member
Entrou: 8 anos atrás
Posts: 4052
29/07/2020 5:26 pm  

Amigo, o que lhe respondi foi apenas o que você disse em seu post. Não vi seu arquivo e nem estou co9m tempo para isso.

Postado por: @tauron

quando os dados são inseridos através do formulário, ele é salvo na planilha "Geral" mas não na planilha "Pericia"

 

Se a resposta foi útil para você, por gentileza, Amigo, clique em Curtir.

Atenciosamente
Wagner Morel


ResponderCitar (Quote)
tauron
(@tauron)
Active Member
Entrou: 1 ano atrás
Posts: 13
30/07/2020 5:59 am  

Muito Obrigado.


ResponderCitar (Quote)
JSCOPA10
(@jscopa10)
Membro Moderator
Entrou: 1 ano atrás
Posts: 152
30/07/2020 8:41 am  

tauron, me dá até febre quando vejo uma planilha com células mescladas k

.

A função índice/corresp aceita esta configuração - =ÍNDICE(Plan1!$A$2:$A$14;CORRESP(A4&B4;Plan1!$B$2:$B$14&Plan1!$C$2:$C$14;0)) - matricial ......... se não testei porque o exemplo que você postou, com 2 linhas, é muito fraquinho!!

.


ResponderCitar (Quote)
Compartilhar: