Notifications
Clear all

Aprendendo a usar ÍNDICE + CORRESP  

Página 1 / 4
  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:04 am  

Esse tutorial é composto por várias imagens...
Se aparecer a frase Você não está autorizado a ver ou baixar esse anexo é porque vc ainda não esta registrado no Fórum....Regístre-se....é rápido, prático e, melhor de tudo, GRÁTIS o/

Vamos começar com a função ÍNDICE()
Primeiro, vamos entendê-la assim...
A função ÍNDICE() retorna o conteúdo da célula indicada...

Vamos dar o exemplo de 1 única coluna procurando em suas LINHAS...
Nessa imagem mostra a fórmula =ÍNDICE(A1:A6;5) retornou Maçã
onde o 5 NÃO é o Nº da linha e sim a 5ª linha começando pela linha 1(A1:A6)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:05 am  

Se fossemos começar pela linha 2(A2) usando a fórmula =ÍNDICE(A2:A6;5)
a fórmula retornaria Morango, pois o 5 NÃO é o Nº da linha e sim a 5ª
linha começando, AGORA, pela linha 2(A2:A6)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:06 am  

Podemos também usar a função ÍNDICE() na horizontal, ou seja, procurar
na linha o conteúdo da COLUNA desejada...
Usando os mesmos critérios da explicação anterior...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:06 am  

ÍNDICE() também pode ser usado dessa maneira, que lembra o PROCV()
=ÍNDICE(A2:C6;3;1) onde 3 é a 3º linha começando pela linha2...e 1 é a
primeira coluna, começando pela coluna A(A2:C6)...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:07 am  

Se trocassemos o 3 pelo numero 2.....e o 1 por 3 a função retornaria Roxo...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:08 am  

Usando agora a função CORRESP() a fórmula ficará perfeita, pois essa
retorna o Nº da célula de um valor procurado...

Ex: A função =CORRESP(C9;A2:A6;0) irá procurar o valor que esta na
célula C9 e retornará o Nº da referência...q no nosso exemplo é 2.
O 0(zero) nessa fórmula é para retornar um valor da referência
exatamente igual ao valor procurado. Por enquanto vamos usar sempre o
0(zero), mais pra frente terá mais detalhes...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:08 am  

Se juntarmos as 2 funções poderíamos fazer uma fórmula assim....
=ÍNDICE(B2:B6;CORRESP(C9;A2:A6;0))
Nesse exemplo a função CORRESP() vai retornar 2...e para a função
ÍNDICE() seria a mesma coisa que =ÍNDICE(B2:B6;2) onde o resultado é 2,50...

Então, podemos usar essa fórmula para procurar um produto em uma lista
e saber o seu Valor!!!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:09 am  

Se quisermos fazer ao contrario tbem pode...digitar um valor para
saber qual produto pertence...
*obs: Caso tenha valor repetido, a fórmula vai retornar o 1º valor

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:09 am  

Fazendo a função ÍNDICE() procurar na tabela inteira ela seria assim...
=ÍNDICE(A2:C6;CORRESP(C9;A2:A6;0);3)
onde o 3 é a coluna a retornar...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:10 am  

Para melhorar a função...podemos fazer o CORRESP() na horizontal para
trazer o Nº da coluna...
=ÍNDICE(A2:C6;CORRESP(C9;A2:A6;0);CORRESP(C10;A1:C1;0))

Onde CORRESP(C9;A2:A6;0) retorna o produto (banana) e
CORRESP(C10;A1:C1;0) retorna a coluna (Cor).

Se vc apenas trocar a palavra COR da célula C10 por Valor...essa
fórmula retornaria 1,50...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
14/08/2009 7:21 am  

Fica aí então o básico sobre ÍNDICE + CORRESP...

Vou ver se eu começo um outro exemplo usando tipo_correspondência do CORRESP() e mais a concaternação e outras coisas...

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
18/08/2009 11:36 pm  

que maravilha hein !!!

parabéns Leo !

abraço

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
19/08/2009 5:21 am  

Show de Bola

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 6:33 am  

Definitivamente este fórum é uma escola!

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
20/08/2009 6:41 am  

Léo,
Muito bom. Bem didático, simples e prático. ;)

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Página 1 / 4
Compartilhar: