ARREDONDAMENTO CONDICIONAL  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

ARREDONDAMENTO CONDICIONAL

Mensagempor liseane » Qui Ago 15, 2019 3:25 pm

Boa tarde a todos,
sou nova no fórum e cheguei a ele pesquisando sobre arredondamento condicional no google... e não encontrei exatamente esse caso que eu tenho, mas tenho esperança de que aqui, com essas mentes geniais, a minha dúvida será fácil de resolver!

tenho uma tabela com 10 linhas, com valores que são multiplicados por uma taxa fixa. Se o resultado do cálculo for um número decimal, quero que seja arredondado para cima, para o próximo número inteiro; e se o resultado for um número inteiro, não é necessário nenhuma alteração. Ex: resultado igual a 2,3 precisa arredondar para 3; resultado igual a 1,5 precisa arredondar para 2.

Agradeço muito se puderem me dar uma luz!

Abraços,

Liseane
liseane
Membro
Membro
 
Mensagens: 3
Registrado em: Qui Ago 15, 2019 3:04 pm
Has thanked: 1 time
Have thanks: 0 time

{ SO_SELECT }

Re: ARREDONDAMENTO CONDICIONAL

Mensagempor JSCOPA10 » Qui Ago 15, 2019 3:36 pm

.
Veja se é isto ... supondo o 2,3 em B1 ... C1 =ARRED(B1;0)
.
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 74
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 7 times
Have thanks: 25 times

Re: ARREDONDAMENTO CONDICIONAL

Mensagempor liseane » Qui Ago 15, 2019 3:42 pm

Oi, no caso =ARRED(B1;0) retornou o próprio número sem a parte decimal em alguns casos... tipo, se erá 2,1 ficou 2. Já em 5,55 retornou 6.
liseane
Membro
Membro
 
Mensagens: 3
Registrado em: Qui Ago 15, 2019 3:04 pm
Has thanked: 1 time
Have thanks: 0 time

Re: ARREDONDAMENTO CONDICIONAL

Mensagempor rlm » Qui Ago 15, 2019 3:45 pm

Creio,se entendi; possa experimentar:--> C1=TETO(B1;1)
Reinaldo - RLM - Rmarco
Gostou da resposta? Clique no ícone "Positivo" da mensagem!(ao lado de citar)
Avatar do usuário
rlm
Ninja do Excel
Ninja do Excel
 
Mensagens: 284
Registrado em: Qui Out 16, 2014 12:30 pm
Has thanked: 18 times
Have thanks: 133 times

Re: ARREDONDAMENTO CONDICIONAL  [Resolvido]

Mensagempor JSCOPA10 » Qui Ago 15, 2019 3:47 pm

.
Então testa esta ............................... C1 =ARRED(TETO(B1;1);0)
.

For this post the author JSCOPA10 thanked:
liseane (Qui Ago 15, 2019 3:54 pm)
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 74
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 7 times
Have thanks: 25 times

Re: ARREDONDAMENTO CONDICIONAL

Mensagempor liseane » Qui Ago 15, 2019 3:52 pm

JSCOPA10"

Sim, essa deu certo - muitíssimo obrigada, JSCOPA10!!!!!!!!!!!!!!!!!!!!!!!!!!

Liseane
liseane
Membro
Membro
 
Mensagens: 3
Registrado em: Qui Ago 15, 2019 3:04 pm
Has thanked: 1 time
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante