Controle de vencimento de exames  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Controle de vencimento de exames

Mensagempor rfps1987 » Qua Jun 12, 2019 4:31 pm

Olá pessoal!

Estou com dificuldade em uma planilha em que fiz para controlar o vencimento dos exames médicos periódicos, quero adicionar uma fórmula em que tem a data do exame (célula E5), a validade (F5) e o prazo (G5), sendo que quero informar nessa planilha quando está vencido, quando está válido e quantos dias faltam pra vencer (máximo 30 dias), adicionando cores (verde, amarelo e vermelho). Exemplo:

funcionário fulano - data do exame 12/06/2019 - válido até 12/06/2020 - válido (verde)
funcionário sicrano - data do exame 10/06/2018 - válido até 10/06/2019 - vencido (vermelho)
funcionário beltrano - data do exame 22/06/2018 - válido até 22/06/2019 -10 dias para vencer (amarelo)

Uso o Excel 2016. Alguém pra me ajudar?
rfps1987
Membro
Membro
 
Mensagens: 5
Registrado em: Qua Jun 12, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

{ SO_SELECT }

Re: Controle de vencimento de exames

Mensagempor Estevaoba » Qua Jun 12, 2019 5:19 pm

Boa tarde e bem-vindo ao fórum.

Para facilitar a criação e teste de fórmulas, favor postar um exemplo de sua planilha, com algumas linhas de datas representativas e coloque o resultado esperado para cada situação.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 489
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 226 times

Re: Controle de vencimento de exames

Mensagempor rfps1987 » Qui Jun 13, 2019 8:25 am

Coloquei o exemplo da planilha no primeiro post, se quiser que eu poste a planilha aqui, eu o faço. Mas como faz a postagem?
rfps1987
Membro
Membro
 
Mensagens: 5
Registrado em: Qua Jun 12, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

Re: Controle de vencimento de exames

Mensagempor deciog » Qui Jun 13, 2019 9:23 am

rfps1987

Poste em site como Sendspace ou 4Shared ou Google Drive outros

Decio
Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Paulo - SP
Décio Gassi
deciog
Membro
Membro
 
Mensagens: 865
Registrado em: Sex Out 02, 2015 2:31 pm
Has thanked: 122 times
Have thanks: 424 times

Re: Controle de vencimento de exames

Mensagempor rfps1987 » Qui Jun 13, 2019 10:33 am

rfps1987
Membro
Membro
 
Mensagens: 5
Registrado em: Qua Jun 12, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

Re: Controle de vencimento de exames  [Resolvido]

Mensagempor Estevaoba » Qui Jun 13, 2019 4:01 pm

Fiz na aba Motoristas

Código: Selecionar todos
F5=SE(E5="";"";DATA(ANO(E5)+1;MÊS(E5);DIA(E5)))

Código: Selecionar todos
G5=SE(E5="";"";SE(E(F5-$D$3>0;F5-$D$3<=30);F5-$D$3&" dias para vencer";SE(F5-$D$3<=0;"VENCIDO";"VÁLIDO")))

Formatação Condicional

Válido (verde)
=$F5-$D$3>30

Faltando 30 ou menos dias para vencer (amarelo)
=E($F5-$D$3>0;$F5-$D$3<=30)

Vencido (vermelho)
=$F5-$D$3<=0

Para fazer a Formatação Condicional:
Selecione toda a coluna G (G5:G220) e clique em:
Formatação Condicional;
Nova regra;
Usar uma fórmula para determinar...
No campo "Formatar valores em que esta fórmula é verdadeira" cole a primeira fórmula (verde).
Selecione a formatação desejada e clique OK.
Repita a operação para as outras cores.

Veja se atende.

Good luck!

For this post the author Estevaoba thanked:
rfps1987 (Sex Jun 14, 2019 11:08 am)
Estevaoba
Membro
Membro
 
Mensagens: 489
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 226 times

Re: Controle de vencimento de exames

Mensagempor rfps1987 » Sex Jun 14, 2019 9:31 am

Na aba "motoristas" deu super certo, mas nas outras abas a fórmula da validade dos exames não funciona, todas as datas que coloca dá o resultado válido.

O que eu faço?
rfps1987
Membro
Membro
 
Mensagens: 5
Registrado em: Qua Jun 12, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

Re: Controle de vencimento de exames

Mensagempor rilust » Sex Jun 14, 2019 10:59 am

prEZADO

Fiz varias alterações na sua planilha como não mantive as abas e o mesmo formato não posso posta-la.

considere
coluna c data do exame
coluna d : data de vencimento
coluna e status
coluna f prazo

temos
COLUNA D ==> =SE(CONT.VALORES(C2)>0;DATAM(C2;12)-1;"")
COLUNA E ==> =SE(CONT.VALORES(C2)<1;"";SE(D2<HOJE();"vencido";"no prazo"))
COLUNA F ==> =SE(CONT.VALORES(C2)<1;"";SE(E2="no prazo";D2-HOJE();""))

observações
1) todas as formulas coloquei se (cont.valores(celula) > 0 para so fazer a formula se a data do exame estiver preenchida
2) usando datam a data de vencimento e preenchida automaticamente mesmo em anos bissextos.
quanto a formatação e so manter o que o colega acima falou mantendo as devidas diferenças de colunas nas demais abaas.

espero ter ajudado
Espero ter Ajudado.
Lembre-se de AGRADECER aos que te ajudaram, e de marcar o tópico como [Resolvido]
rilust
Membro
Membro
 
Mensagens: 460
Registrado em: Ter Jun 16, 2015 5:23 pm
Has thanked: 96 times
Have thanks: 173 times

Re: Controle de vencimento de exames

Mensagempor rfps1987 » Sex Jun 14, 2019 4:34 pm

Amigos, consegui resolver o meu problema, as fórmulas que o estevão postou deu muito certo!

Obrigado pela ajuda!
rfps1987
Membro
Membro
 
Mensagens: 5
Registrado em: Qua Jun 12, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante