HORA DIURNA e NOTURNA ... separando!!  [Resolvido]

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

HORA DIURNA e NOTURNA ... separando!!

Mensagempor JSCOPA » Dom Abr 14, 2019 5:46 pm

OBS1:
.
1) Considerando que essa pergunta sempre aparece nos fóruns, estou tentando montar um gabarito/paradigma para essas situações!
.
2) O cálculo considera que ninguém NUNCA vai trabalhar mais de 24h seguidas!!
.
3) Sei que a HE noite tem um cálculo diferente (*60/52,5) mas isto será feito em outro momento, o objetivo agora é apenas separar o que é hora diurna e noturna!!
.
4) as colunas C e D são iguais, mas com fórmulas diferentes só para aferir/confirmar!!
.
5) Resolvendo a coluna E, se resolve a coluna F ... Mas travei nas células amarelas!!
.
6) Alguém dá uma luz??????????????????????????? ... Não é minha necessidade no momento, a intenção é ter um tópico com a solução para as passadas e futuras perguntas!!!
.
JSCOPA
 

{ SO_SELECT }

Re: HORA DIURNA e NOTURNA ... separando!!  [Resolvido]

Mensagempor Estevaoba » Dom Abr 14, 2019 8:54 pm

Boa noite, nobre!

Tente esta:

Código: Selecionar todos
E4=SE(E(MOD(B4;1)>MOD(A4;1);MOD(A4;1)<$B$1;MOD(B4;1)<=$B$1;MOD(A4;1)>$B$2);0;SE(E(MOD(B4;1)>$B$1;MOD(A4;1)<$B$1);MOD(B4;1)-$B$1;SE(E(MOD(A4;1)>$B$2;MOD(B4;1)<MOD(A4;1);MOD(B4;1)<=$B$2);1+MOD(B4;1)-$B$1;SE(E(MOD(A4;1)>$B$2;MOD(B4;1)<MOD(A4;1);MOD(B4;1)>$B$2;MOD(A4;1)<=$B$1);1+$B$2-$B$1;SE(E(MOD(B4;1)<$B$1;MOD(A4;1)<$B$1;MOD(A4;1)<$B$2);$B$2-MOD(A4;1);1+$B$2-MOD(A4;1))))))


Espero ter coberto todas as possibilidades.

Editei.
Faltava cobrir uma variante pra fechar as últimas linhas.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 458
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 216 times


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante