Dúvida de Falso e Verdadeiro  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Dúvida de Falso e Verdadeiro

Mensagempor vonzuben » Sáb Ago 11, 2018 4:06 pm

Pq o primeiro código tive que colocar vazio primeiro e no segundo código ao contrário ?
Código: Selecionar todos
P4 tem o ano 2018
=SE(HOJE()>CONCATENAR("27/1/";P4);"";M2+N2)

Código: Selecionar todos
M2 = 40
N2 = 20
=SE(M2>N2;10+10;"")


Obrigado !
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

{ SO_SELECT }

Re: Dúvida de Falso e Verdadeiro

Mensagempor Patropi » Sáb Ago 11, 2018 4:40 pm

Boa tarde

Não analisei a tua formula porque você não anexou a planilha, mas a lógica da função SE é a seguinte.

Se o critério for atendido, verdadeiro, senão falso.

No caso, se você quer que retorne em branco quando for verdadeiro deixa o vazio por primeiro, e caso contrário, o vazio é por último.

Se foi útil, clique em Curtir.

[]s
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.

For this post the author Patropi thanked:
vonzuben (Sáb Ago 11, 2018 9:32 pm)
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 8795
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 214 times
Have thanks: 3484 times

Re: Dúvida de Falso e Verdadeiro

Mensagempor vonzuben » Sáb Ago 11, 2018 7:39 pm

Então :
Se Hoje ( 11/08/2018) > que 27/1/2018, então soma, senão, vazio, mas se eu colocar primeiro a soma ele considera como vazio, lembrando que 11/08/2018 é maior que 27/1/2018 ( verdadeiro e depois Falso)

Fiz um exemplo na planilha, ambos são verdadeiro e depois falso

"No caso, se você quer que retorne em branco quando for verdadeiro deixa o vazio por primeiro, e caso contrário, o vazio é por último." ( Deixei em último e não retornou a soma do código 1)
Você não está autorizado a ver ou baixar esse anexo.
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

Re: Dúvida de Falso e Verdadeiro  [Resolvido]

Mensagempor wzxnet7 » Sáb Ago 11, 2018 8:08 pm

A função concatenar devolve um valor de texto.
Para obter o resultado que pretende, digite em "D3":
Código: Selecionar todos
=SE(HOJE()>CONCATENAR("27/1/";A3)+0;B3+C3;"")
Resposta útil? Clique na mãozinha ao lado do botão Citar.

For this post the author wzxnet7 thanked:
vonzuben (Sáb Ago 11, 2018 9:33 pm)
Avatar do usuário
wzxnet7
Membro
Membro
 
Mensagens: 681
Registrado em: Qui Jul 21, 2016 10:26 am
Has thanked: 40 times
Have thanks: 356 times

Re: Dúvida de Falso e Verdadeiro

Mensagempor vonzuben » Sáb Ago 11, 2018 9:33 pm

Agora sim, explicado !
Obrigado!
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 4 visitantes