Fórmula com DATA  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Fórmula com DATA

Mensagempor tiago21 » Sex Ago 10, 2018 3:17 pm

Olá pessoal.

Essa fórmula abaixo retorna a data inicial da semana que eu digito na célula C1 com o ano na célula A1.
=MÁXIMO(DATA(A1;1;1);DATA(A1;1;1)-DIA.DA.SEMANA(DATA(A1;1;1);14)+(C1-1)*7+1)

Essa retorna a data final da semana.
=MÍNIMO(DATA(A1+1;1;0);DATA(A1;1;1)-DIA.DA.SEMANA(DATA(A1;1;1);14)+C1*7)

O problema é que tenho que fazer a seguinte lógica:
Se a data final da semana mudar de mês, eu quero que ela pegue o último dia do mês da data inicial.
Exemplo: A semana 31 (começando na quinta-feira) começa no dia 26/07 e acaba no dia 01/08... logo o resultado da data final para trazer seria o dia 31/08. Se alguém conseguir ajudar, obg.
tiago21
Membro
Membro
 
Mensagens: 37
Registrado em: Seg Out 09, 2017 11:27 am
Has thanked: 10 times
Have thanks: 0 time

{ SO_SELECT }

Re: Fórmula com DATA  [Resolvido]

Mensagempor xlarruda » Sex Ago 10, 2018 4:14 pm

Segue:

Código: Selecionar todos
=SE(MÊS(MÍNIMO(DATA(A1+1;1;0);DATA(A1;1;1)-DIA.DA.SEMANA(DATA(A1;1;1);14)+C1*7))>MÊS(MÁXIMO(DATA(A1;1;1);DATA(A1;1;1)-DIA.DA.SEMANA(DATA(A1;1;1);14)+(C1-1)*7+1));FIMMÊS(MÁXIMO(DATA(A1;1;1);DATA(A1;1;1)-DIA.DA.SEMANA(DATA(A1;1;1);14)+(C1-1)*7+1);0);"Mesmo Mês")
___________________________________________________________________________________________
Se a resposta atendeu sua dúvida, por favor, clique no Gostei e marque o Tópico como [Resolvido].

Att.

André Arruda

For this post the author xlarruda thanked:
tiago21 (Sex Ago 10, 2018 4:23 pm)
Avatar do usuário
xlarruda
Membro
Membro
 
Mensagens: 761
Registrado em: Qua Out 04, 2017 9:41 am
Localização: Cuiabá-MT
Has thanked: 95 times
Have thanks: 307 times

Re: Fórmula com DATA

Mensagempor tiago21 » Sex Ago 10, 2018 4:23 pm

Resolvido. Obrigado.
tiago21
Membro
Membro
 
Mensagens: 37
Registrado em: Seg Out 09, 2017 11:27 am
Has thanked: 10 times
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 5 visitantes