Como saber se o penúltimo é número

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Como saber se o penúltimo é número

Mensagempor vonzuben » Sex Jun 15, 2018 12:20 am

Quero saber se o penúltimo é numero e o se último é letra

Código: Selecionar todos
=SE(E(ÉNÚM=DIREITA(A3;2);DIREITA(A3;1)="F");"Correto";"FALSO")


Ex: Cod1F

Obrigado !
vonzuben
Membro
Membro
 
Mensagens: 498
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 191 times
Have thanks: 0 time

{ SO_SELECT }

Re: Como saber se o penúltimo é número

Mensagempor xlarruda » Sex Jun 15, 2018 9:17 am

Segue:

Código: Selecionar todos
=SE(E(ÉNÚM(VALOR(EXT.TEXTO(A3;NÚM.CARACT(A3)-1;1)))=VERDADEIRO;ÉNÚM(VALOR(DIREITA(A3;1)))=FALSO);"Correto";"FALSO")
___________________________________________________________________________________________
Se a resposta atendeu sua dúvida, por favor, clique no Gostei e marque o Tópico como RESOLVIDO.

Att.

André Arruda
Avatar do usuário
xlarruda
Membro
Membro
 
Mensagens: 531
Registrado em: Qua Out 04, 2017 9:41 am
Localização: Cuiabá-MT
Has thanked: 81 times
Have thanks: 211 times

Re: Como saber se o penúltimo é número

Mensagempor wagner » Sex Jun 15, 2018 12:24 pm

vonzuben,

Boa tarde!

Segue minha contribuição com o uso de VBA.
Você não está autorizado a ver ou baixar esse anexo.
Se a resposta foi útil para você, por gentileza, Amigo, clique na mãozinha ao lado direito da ferramenta CITAR, no canto superior direito.

Atenciosamente
Wagner Morel
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 3920
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 65 times
Have thanks: 1681 times


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: laisg e 2 visitantes