Formula com varias planilhas  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Formula com varias planilhas

Mensagempor MEDALHA » Sex Out 25, 2019 4:36 pm

Boa tarde.

No link abaixo contem duas planilhas, preciso usar o conteúdo da planilha CALULO DE VERBAS 2019-2020 na planilha TESTE, no mês de out 19 (TESTE) já há uma célula com a formula funcionando, porem gostaria de usar o valor da planilha CALCULO DE VERBAS 2019-2020, pois tenho varias planilhas que usam a mesma formula.
Desde já meu muito obrigado.

https://www.sendspace.com/filegroup/5QD ... syhmKZxxlg
MEDALHA
Membro
Membro
 
Mensagens: 4
Registrado em: Qua Out 02, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

{ SO_SELECT }

Re: Formula com varias planilhas

Mensagempor Estevaoba » Sáb Nov 02, 2019 10:10 pm

Para viabilizar uma solução, sugiro as seguintes alterações:

Planilhas TESTE e Calculo Verbas:
Para poder usar a função INDIRETO, alterar os títulos de abas de mês de forma que elimine espaços, por exemplo, mude Out 19 para Out_19

Planilha TESTE, célula A1 de todas as abas de mês:
Para exibir o título da aba, cole esta fórmula:
Código: Selecionar todos
=DIREITA(CÉL("nome.arquivo";Z1); NÚM.CARACT(CÉL("nome.arquivo"; Z1))- LOCALIZAR("]";CÉL("nome.arquivo";Z1)))


Finalmente, a sua fórmula na planilha TESTE ficaria assim:
Código: Selecionar todos
E3=SE(D3="";INDIRETO("'[Calculo Verbas 2019-2020.xlsx]"&$A$1&"'!$G$33");SE(MÊS(D3)<INDIRETO("'[Calculo Verbas 2019-2020.xlsx]"&$A$1&"'!$K$1");INDIRETO("'[Calculo Verbas 2019-2020.xlsx]"&$A$1&"'!$P$2");SE(MÊS(D3)=INDIRETO("'[Calculo Verbas 2019-2020.xlsx]"&$A$1&"'!$K$1");PROCV(DIA(D3);INDIRETO("'[Calculo Verbas 2019-2020.xlsx]"&$A$1&"'!F36:J66");2);0)))


Dessa forma você poderá buscar valores das abas para cada mês da planilha Calculo Verbas.

Good luck!

For this post the author Estevaoba thanked:
MEDALHA (Ter Nov 05, 2019 9:51 am)
Estevaoba
Membro
Membro
 
Mensagens: 528
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 240 times

Re: Formula com varias planilhas

Mensagempor MEDALHA » Ter Nov 05, 2019 10:09 am

Muito obrigado.

Tenho uma outra planilha em anexo, precisava que movesse o conteúdo da celular A1 para a aba RESUMO, como está com o valor de cada aba, não sei qual formula usar,uma que teste os nomes da aba RESUMO com as outra aba MÊS e move a célula A1.

https://www.sendspace.com/file/jnvqlt
MEDALHA
Membro
Membro
 
Mensagens: 4
Registrado em: Qua Out 02, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

Re: Formula com varias planilhas

Mensagempor Estevaoba » Ter Nov 05, 2019 7:24 pm

De nada. Fico feliz por ajudar.

Tente:

Código: Selecionar todos
O6=SE(É.NÃO.DISP(CORRESP(C6;INDIRETO($O$5&"!C:C");0));0;INDIRETO($O$5&"!A:A"))

Copie para preencher a coluna.
E nas outras colunas altere a fórmula para:

Código: Selecionar todos
G6=SOMASE(INDIRETO(G$5&"!C:C");$C6;INDIRETO(G$5&"!D:D"))

Copie para preencher a tabela.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 528
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 240 times

Re: Formula com varias planilhas

Mensagempor MEDALHA » Qua Nov 06, 2019 9:29 am

Bom dia.
Em anexo planilha com a alteração que passou, mas há inconsistência, como pode ser observado na aba 082019V a célula A11 seu conteúdo é N e na aba RESUMO a célula J13 (em destaque) que é referencia a A11 contem S, se possível poderia verificar?


https://fs05u.sendspace.com/upload?SPEE ... TION_DIR=7
MEDALHA
Membro
Membro
 
Mensagens: 4
Registrado em: Qua Out 02, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time

Re: Formula com varias planilhas  [Resolvido]

Mensagempor Estevaoba » Qui Nov 07, 2019 8:06 pm

Tente desta outra forma:

Código: Selecionar todos
=SE(É.NÃO.DISP(CORRESP(C6;INDIRETO($P$5&"!C:C");0));0;ÍNDICE(INDIRETO($P$5&"!A:A");CORRESP(C6;INDIRETO($P$5&"!C:C");0)))


Ab.
Estevaoba
Membro
Membro
 
Mensagens: 528
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 240 times

Re: Formula com varias planilhas

Mensagempor MEDALHA » Sex Nov 08, 2019 8:01 am

Muito obrigado. Agora ficou correto.
MEDALHA
Membro
Membro
 
Mensagens: 4
Registrado em: Qua Out 02, 2019 4:10 pm
Has thanked: 1 time
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Google [Bot] e 2 visitantes