Dúvida com somas e Procv!

Como pintar uma célula, como formatar uma borda, funções básicas! Se você não sabe em que categoria postar a sua dúvida, escreva aqui que depois nós mudamos o tópico.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Dúvida com somas e Procv!

Mensagempor osama2003 » 09 Mar 2010, 21:21

Ola galera, curto muito o excel, mas to apanhando demais dele, vamo ve se vcs podem me ajudar:

Tenho em 1 linha várias células com a formula procv, cada celula tem sua formula. O Procv, quando não possui um resultado, aparece a seguinte mensagem #N/D, ou #valor!. ok.

No final dessa linha, queria somar todas as celulas que me trouxessem algum resultado válido (qualquer numero maior que zero) porém não estou conseguindo com a formula SOMA pq, se tiver alguma célula com #N/D ou #Valor!, a fórmula SOMA simplesmente não soma. heehhe

Qual outra fórmula posso usar? o SOMASE?

abs e valeu!!! ;)
Avatar do usuário
osama2003
Membro
Membro
 
Mensagens: 6
Registrado em: 10 Nov 2009, 10:26
Agradeceu : 0 time
Foi agradecido: 0 time

Re: Dúvida com somas e Procv!

Mensagempor leonardojones » 10 Mar 2010, 12:04

Use o ÉERROS() antes da sua formula dos PROCV()

Ficaria assim....
=SE(ÉERROS(sua_formula);"";sua_formula)
Att,
Leonardo Jones
Moderação
http://www.planilhando.com.br - Seu forum de Excel
E-Mail: leo@planilhando.com.br MSN: leonardojonescosta@msn.com
Avatar do usuário
leonardojones
Ninja do Excel
Ninja do Excel
 
Mensagens: 1117
Registrado em: 03 Jul 2009, 20:24
Agradeceu : 2 vezes
Foi agradecido: 103 vezes

Re: Dúvida com somas e Procv!

Mensagempor osama2003 » 11 Mar 2010, 20:30

Valeu Leonardo, vou tentar aqui e ja dou uma resposta! Obrigado mesmo!
Avatar do usuário
osama2003
Membro
Membro
 
Mensagens: 6
Registrado em: 10 Nov 2009, 10:26
Agradeceu : 0 time
Foi agradecido: 0 time

Re: Dúvida com somas e Procv!

Mensagempor osama2003 » 14 Mar 2010, 16:11

nada feito Leonardo, aparece a seguinte mensagem de erro:

"O valor inserido não é válido.
Outro usuário restringiu valores que podem ser inseridos nesta célula."

Leonardo, minha fórmula é a seguinte:

=PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;"FALSO")/100*Dieta!$I$38

como ficaria imbutindo ÉERROS nesta fórmula?
valeu!!! ;)
Avatar do usuário
osama2003
Membro
Membro
 
Mensagens: 6
Registrado em: 10 Nov 2009, 10:26
Agradeceu : 0 time
Foi agradecido: 0 time

Re: Dúvida com somas e Procv!

Mensagempor Edson » 14 Mar 2010, 21:38

=SE(ÉERROS(PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;0));"";PROCV(Dieta!$C$38;BD!$B$6:$AX$501;3;0)/100*Dieta!$I$38)
Edson Faria

"O impossível é uma questão de tempo." (Alberto Saltiel)
Avatar do usuário
Edson
Ninja do Excel
Ninja do Excel
 
Mensagens: 776
Registrado em: 06 Jul 2009, 00:41
Localização: São Paulo - SP
Agradeceu : 25 vezes
Foi agradecido: 117 vezes

Re: Dúvida com somas e Procv!

Mensagempor leonardojones » 15 Mar 2010, 19:27

Exato!!!
Att,
Leonardo Jones
Moderação
http://www.planilhando.com.br - Seu forum de Excel
E-Mail: leo@planilhando.com.br MSN: leonardojonescosta@msn.com
Avatar do usuário
leonardojones
Ninja do Excel
Ninja do Excel
 
Mensagens: 1117
Registrado em: 03 Jul 2009, 20:24
Agradeceu : 2 vezes
Foi agradecido: 103 vezes


Voltar para Excel - O básico

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 3 visitantes