DATA FINAL PROGRAMADA ULTRAPASSA NUMERO DE AULAS INFORMADO  [Resolvido]

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

DATA FINAL PROGRAMADA ULTRAPASSA NUMERO DE AULAS INFORMADO

Mensagempor nilson1978 » Ter Set 18, 2018 12:24 am

Bom dia,
A alguns dias atrás solicitei uma ajuda do nosso ilustríssimo amigo ( Estevaoba), que me foi muito útil, porém pondo em prática me deparei com um problema que não estou encontrando a solução
Tenho que montar um quandro de aulas de x aulas sendo que as aulas são sempre no mesmo dia da semana, sempre que tiver feriado e/ou data comemorativa pular para a outra semana, até ai tudo bem, contudo em alguns casos se houver feriados ninha grade ultrapassa o limite de aulas planejados.
se alguem puder me dar uma luz, onde estou errando, ficarei grato.


essa foi a sugestão que recebi(Porém nao sei como reabrir o tópico, por isso estou pedindo a ajuda)
B7=SEERRO(SE(NÃO(É.NÃO.DISP(CORRESP(B6+7;Tabela3[[Data ]];0)));B6+14;SE(DIATRABALHOTOTAL($B$1;B6;Tabela3[[Data ]])<DIATRABALHOTOTAL($B$1;$B$2;Tabela3[[Data ]]);B6+7;SE(CONT.VALORES(B$6:B6)<$B$3;B6+7;"")));"")
Você não está autorizado a ver ou baixar esse anexo.
nilson1978
Membro
Membro
 
Mensagens: 69
Registrado em: Qui Abr 20, 2017 7:07 pm
Has thanked: 20 times
Have thanks: 1 time

{ SO_SELECT }

Re: DATA FINAL PROGRAMADA ULTRAPASSA NUMERO DE AULAS INFORMA  [Resolvido]

Mensagempor deciog » Qua Set 19, 2018 8:30 am

nilson1978, Bom Dia.

Uma forma simples de fazer confere

=SE(B9>$D$5;"";SEERRO(SE(NÃO(É.NÃO.DISP(CORRESP(D8+7;Tabela3[[Data ]];0)));D8+14;SE(DIATRABALHOTOTAL($D$2;D8;Tabela3[[Data ]])<DIATRABALHOTOTAL($D$2;$D$3;Tabela3[[Data ]]);D8+7;SE(CONT.VALORES(D$8:D8)<$D$5;D8+7;"")));""))

Se foi útil, clique na mãozinha é uma forma de agradecimento

Decio
Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Pulo - SP
Décio Gassi

For this post the author deciog thanked:
nilson1978 (Sex Set 21, 2018 8:53 pm)
deciog
Membro
Membro
 
Mensagens: 719
Registrado em: Sex Out 02, 2015 2:31 pm
Has thanked: 119 times
Have thanks: 344 times

Re: DATA FINAL PROGRAMADA ULTRAPASSA NUMERO DE AULAS INFORMA

Mensagempor nilson1978 » Sex Set 21, 2018 8:54 pm

Muitíssimo obrigado
nilson1978
Membro
Membro
 
Mensagens: 69
Registrado em: Qui Abr 20, 2017 7:07 pm
Has thanked: 20 times
Have thanks: 1 time


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante