AVOS DE FERIAS  [Resolvido]

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

AVOS DE FERIAS

Mensagempor rilust » Sex Ago 09, 2019 2:04 pm

PREZADOS

Preciso calcular o avos de férias.. Conta-se o mês como trabalhado se o funcionario trabalhou 15 dias ou mais no mês. Examinei várias soluções postadas no forum mas nenhuma funcionou. (uma delas encontrou 18/12 avos).

Em relação ao avos de 13 já fiz a formula. se alguém puder testar agradeço

https://www.sendspace.com/file/e8wdwc

Desde já agradeço
No aguardo.
Espero ter Ajudado.
Lembre-se de AGRADECER aos que te ajudaram, e de marcar o tópico como [Resolvido]
rilust
Membro
Membro
 
Mensagens: 458
Registrado em: Ter Jun 16, 2015 5:23 pm
Has thanked: 96 times
Have thanks: 169 times

{ SO_SELECT }

Re: AVOS DE FERIAS

Mensagempor Adalberto7 » Sex Ago 09, 2019 8:39 pm

Boa noite

Eu conferi o resultado da tua fórmula utilizando a minha que posto abaixo e todos os resultados bateram:

Código: Selecionar todos
=SE(OU(A2="";B2="";A2>B2);0;MÊS(B2)-SE(DIA(B2)<15;1;0)-SE(ANO(B2)<>ANO(A2);0;(MÊS(A2)+SE(DATA(ANO(B2);MÊS(A2)+1;DIA(0))-DATA(ANO(B2);MÊS(A2);DIA(A2))+1<15;1;0))-1))&" avos"


[]s
Antigo Patropi
Se foi útil, clique na mãozinha

For this post the author Adalberto7 thanked:
rilust (Sáb Ago 10, 2019 11:08 am)
Avatar do usuário
Adalberto7
Ninja do Excel
Ninja do Excel
 
Mensagens: 74
Registrado em: Qua Jun 19, 2019 9:33 pm
Has thanked: 3 times
Have thanks: 22 times

Re: AVOS DE FERIAS

Mensagempor rilust » Sáb Ago 10, 2019 11:07 am

prezado patropi

Realmente a sua formula funciona. Agradeço .

No entanto o titulo do topico e avos de ferias. Assim sendo o que preciso são os avos de férias e no inicio da mensagem coloquei "Preciso calcular o avos de férias.."

Se você puder bolar uma formula para as ferias agradeço.

No aguardo
Espero ter Ajudado.
Lembre-se de AGRADECER aos que te ajudaram, e de marcar o tópico como [Resolvido]
rilust
Membro
Membro
 
Mensagens: 458
Registrado em: Ter Jun 16, 2015 5:23 pm
Has thanked: 96 times
Have thanks: 169 times

Re: AVOS DE FERIAS

Mensagempor Adalberto7 » Sáb Ago 10, 2019 1:43 pm

Boa tarde

Eu havia atendido esta parte aqui:
Em relação ao avos de 13 já fiz a formula. se alguém puder testar agradeço

Quanto ao cálculo do proporcional de férias, o que muda é que é contado a partir do mês de admissão e não meses do ano corrente.
Exemplo: Data de admissão: 10/10/2018, vai começar a contar os avos a partir de dessa data e não de janeiro como seria no 13º, deste caso.

Já temos tópicos sobre o assunto aqui no fórum, como esse aqui:

viewtopic.php?f=29&t=11678

[]s
Antigo Patropi
Se foi útil, clique na mãozinha

For this post the author Adalberto7 thanked:
rilust (Sáb Ago 10, 2019 9:56 pm)
Avatar do usuário
Adalberto7
Ninja do Excel
Ninja do Excel
 
Mensagens: 74
Registrado em: Qua Jun 19, 2019 9:33 pm
Has thanked: 3 times
Have thanks: 22 times

Re: AVOS DE FERIAS  [Resolvido]

Mensagempor JSCOPA10 » Dom Ago 11, 2019 11:19 am

.
rilust, testa aí ..... Aba férias ... E2 =SE(DATADIF(A2;B2;"md")>=15;DATADIF(A2;B2;"ym")+1;DATADIF(A2;B2;"ym"))
.
PS: Considerei que, se o empregado tem 5 anos e 9 meses de casa, ele já tirou as 5 férias, só falta os 9 avos/meses!!
.
Editando para postar o arquivo e deixar o tópico mais completo .... https://www.sendspace.com/file/eak7br
.

For this post the author JSCOPA10 thanked:
rilust (Ter Ago 13, 2019 9:14 am)
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 74
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 7 times
Have thanks: 25 times

Re: AVOS DE FERIAS

Mensagempor rilust » Ter Ago 13, 2019 9:14 am

valeu resolveu
Espero ter Ajudado.
Lembre-se de AGRADECER aos que te ajudaram, e de marcar o tópico como [Resolvido]
rilust
Membro
Membro
 
Mensagens: 458
Registrado em: Ter Jun 16, 2015 5:23 pm
Has thanked: 96 times
Have thanks: 169 times


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes