dias e horas faltante em uma lista

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

dias e horas faltante em uma lista

Mensagempor MIRANDAMN » Seg Nov 19, 2018 12:53 pm

Bom dia!



Gostaria que alguém me ajudasse, pois estou tendo dificuldade para solucionar um pequeno problema, tenho uma planilha de Excel 2013, onde há coluna com data e hora personalizada, exemplo: 01/10/2018 00:00, até 31/10/2018 23:00, sendo que nessa listagem faltam alguns horários. É ai que entra a dificuldade, preciso encontrar esses horários que faltam, e não consigo encontrar a formula correta. Alguém poderia mim ajudar?
MIRANDAMN
Membro
Membro
 
Mensagens: 2
Registrado em: Seg Nov 19, 2018 12:46 pm
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Re: dias e horas faltante em uma lista

Mensagempor JSCOPA » Seg Nov 19, 2018 1:44 pm

.
Sugiro que você poste uma planilha exemplo (com pelo menos umas 10 linhas - e o resultado esperado) ... assim a solução sai rápido, já que não precisaremos montar um modelo!!!
JSCOPA
.
Se a resposta foi útil, agradeça clicando na mãozinha!! ... Se resolveu, clique em "resolvido"!!
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 1576
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 227 times
Have thanks: 477 times

Re: dias e horas faltante em uma lista

Mensagempor MIRANDAMN » Seg Nov 19, 2018 2:20 pm

O que preciso é encontrar se há na coluna A alguns horários faltando, como pode ser visto no anexo.
Você não está autorizado a ver ou baixar esse anexo.
MIRANDAMN
Membro
Membro
 
Mensagens: 2
Registrado em: Seg Nov 19, 2018 12:46 pm
Has thanked: 0 time
Have thanks: 0 time

Re: dias e horas faltante em uma lista

Mensagempor Estevaoba » Sex Dez 28, 2018 3:03 pm

Uso esta fórmula para listar os horários faltantes em uma coluna auxiliar, por exemplo, coluna F:

Código: Selecionar todos
F2=SE(QUOCIENTE(LIN(Z1);24)+INT(A$2)+"01:00"*(MOD(LIN()-1;24)-1)>MÁXIMO($A$2:$A$41);"";SE(É.NÃO.DISP(CORRESP(QUOCIENTE(LIN(Z1);24)+INT(A$2)+"01:00"*(MOD(LIN()-1;24)-1);$A$2:$A$41;0));QUOCIENTE(LIN(Z1);24)+INT(A$2)+"01:00"*(MOD(LIN()-1;24)-1);""))


Copiar para baixo até preencher tantas linhas quanto os horários possíveis, no caso, 48, ou seja, até a linha 49 pelo menos.

Em outra coluna, E, por exemplo, uso esta fórmula matricial (ctrl+shift+enter) para exibir os horários faltantes sem espaços em branco:

Código: Selecionar todos
E2=SEERRO(ÍNDICE($F$2:$F$68;CORRESP(1;(CONT.SE(E$1:E1;$F$2:$F$68)=0)*($F$2:$F$68<>"");0));"")


Copiar para baixo até parar de exibir valores.

Good luck!
Você não está autorizado a ver ou baixar esse anexo.
Estevaoba
Membro
Membro
 
Mensagens: 436
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 48 times
Have thanks: 210 times


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante