Como calcular horas extras eliminando horas sobrepostas.

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Wilian F R » Qui Abr 05, 2018 5:57 pm

Boa tarde galera. Estou quebrando a cabeça para conseguir somar as horas extras feitas durante o plantão aqui na empresa. Obs.: toda hora trabalhada no plantão é extra. O problema é que são vários atendimento feitos durante o plantão, e alguns iniciam antes de terminar o anterior. Com isso duplica o horário trabalhado. Ex: 1º Atend: das 18:30 as 19:00; 2º Atend: 18:35 as 19:06; 3º Atend: 18:40 as 18:56. A empresa não quer que some os minutos duplicados. Utilizei as fórmulas "SE" e "E" juntas, porém ficou uma fórmula muito grande e não absorveu todas as condições necessário, deixando a fórmula com falhas. Segue em anexo a planilha. Peço a ajuda de alguém. Desde já agradeço a atenção.

Att,

Wilian F. R.
Você não está autorizado a ver ou baixar esse anexo.
Wilian F R
Membro
Membro
 
Mensagens: 2
Registrado em: Qui Abr 05, 2018 11:57 am
Has thanked: 2 times
Have thanks: 0 time

{ SO_SELECT }

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Patropi » Qui Abr 05, 2018 6:19 pm

Wilian

Movi teu tópico para Datas & Horas, que é o assunto da tua dúvida, pois onde você havia postado é exclusivo para a apresentação dos novos usuários.

Como você é novato, para facilitar a tua participação, sugiro tomar conhecimento do conteúdo dos links abaixo:
viewtopic.php?f=7&t=16757
viewtopic.php?f=7&t=203
viewtopic.php?f=7&t=7903
viewtopic.php?f=7&t=3841
viewtopic.php?f=7&t=12600
viewtopic.php?f=7&t=3371

[]s
Patropi - Moderador
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.

For this post the author Patropi thanked:
Wilian F R (Qui Abr 05, 2018 6:39 pm)
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 8654
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 210 times
Have thanks: 3414 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Wilian F R » Seg Jun 25, 2018 12:23 pm

Bom dia. Ainda não consegui resolver esse problema. Será que alguém consegue me ajudar? Essa planilha é de fundamental importância para mim. Se alguém puder ajudar agradeço.

Wilian
Wilian F R
Membro
Membro
 
Mensagens: 2
Registrado em: Qui Abr 05, 2018 11:57 am
Has thanked: 2 times
Have thanks: 0 time

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Estevaoba » Ter Jul 10, 2018 4:26 pm

Tente esta fórmula em P12 da aba PLANTÃO:

Código: Selecionar todos
=SE(L12="";"";SOMARPRODUTO((CONT.SES($A$4:$A$62;L12;$B$4:$B$62;">="&M12;$C$4:$C$62;"<="&N12;$B$4:$B$62;"<"&MÍNIMO($B$4:$B$62)+LIN(INDIRETO("1:"&ARRED((MÁXIMO($C$4:$C$62)-MÍNIMO($B$4:$B$62))*1440;0)))/1440-1/2880;$C$4:$C$62;">"&MÍNIMO($B$4:$B$62)+LIN(INDIRETO("1:"&ARRED((MÁXIMO($C$4:$C$62)-MÍNIMO($B$4:$B$62))*1440;0)))/1440-1/2880)>0)+0)/60/24)


E copie para preencher a coluna.

Note que nas datas em que a hora de saída ultrapassa 22:00, o valor resulta incorreto.
Para contornar isso, mude o limite na coluna N de 22:00 para 23:00.

Good luck!
Estevaoba
Membro
Membro
 
Mensagens: 368
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 42 times
Have thanks: 170 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor JSCOPA » Ter Jul 10, 2018 5:24 pm

.
Se é o que entendi, fica aí outra sugestão ................. E4 =SE(A4=A5;"";SOMASE($A$4:$A$100;A4;$D$4:$D$100)) ... arrasta até o final ...
.
JSCOPA
.
Se a resposta foi útil, agradeça clicando na mãozinha!! ... Se resolveu, clique em "resolvido"!!
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 1157
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 189 times
Have thanks: 287 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor JSCOPA » Ter Jul 10, 2018 8:07 pm

.
Wilian, quando eu não encontro a chave de fenda, uso o martelo mesmo kk ... se não aparecer nada melhor, este esquema resolve ... testa aí, e diga o que acha ...
.
Ops!!! ... Mesmo zipado ficou com 220kb, o aqui só aceita até 50kb!! ... Manda seu email por MP que te envio, se resolver, você informa aqui que resolveu, se não fala também para que outros tentem outra solução!!
.
JSCOPA
.
Se a resposta foi útil, agradeça clicando na mãozinha!! ... Se resolveu, clique em "resolvido"!!
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 1157
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 189 times
Have thanks: 287 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Estevaoba » Ter Jul 10, 2018 8:33 pm

Dá pra postar só as fórmulas, Copa?
Essa questão que ele levantou eu achei interessante e de solução complicada.
E pensei que alguém viria com algum código VBA.
A fórmula que postei eu encontrei num fórum estrangeiro e adaptei.
Vamos ver o que ele diz.
Mas fiquei curioso por sua solução.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 368
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 42 times
Have thanks: 170 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor JSCOPA » Ter Jul 10, 2018 9:12 pm

.
Estevaoba, ficou curioso? k ... É uma solução super gambiarra, mas que parece que resolve k! ... Como a base será feita só uma vez, e depois ficará escondida num canto da plan, não é nada grave!!
.
Com base no arquivo que ele postou:
.
É só colocar em AE3: 00:01, em AF3: 00:02 ... e arrastar até BDN3 (24:00) ... em BDO4 =SOMA(AE4:BDN4)/60/24 (formatar para hora) ... BDP4 =SE(A4<>A3;SOMASE($A$4:$A$100;A4;$BDO$4:$BDO$100);"")
.
AE4 =SE(E($A4=$A3;AE3<>1;AE2<>1;$B4<AE$3;$C4>=AE$3);1;SE(E($A4<>$A3;$B4<AE$3;$C4>=AE$3);1;"")) ... arrasta até BDN100 ...
.
F4 =BDP4 ... arrasta até F100
.
R12 =ÍNDICE($F$4:$F$100;CORRESP(M12;$A$4:$A$100;0)) ... arrasta até R100
.
Pronto!!
.
JSCOPA
.
Se a resposta foi útil, agradeça clicando na mãozinha!! ... Se resolveu, clique em "resolvido"!!
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 1157
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 189 times
Have thanks: 287 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor Estevaoba » Ter Jul 10, 2018 9:56 pm

Bacana!
Fiz aqui os seus cálculos e chega em resultados bem próximos do que ele quer.
No dia 14, o resultado esperado era 2:19 e você chegou em 2:32, ou seja, algumas sobreposições permaneceram.
E faltou levar em conta as horas trabalhadas por turnos. Por exemplo, dia 18 tem dois turnos. Você chegou a um valor que é a soma dos dois turnos.
Eu comecei a criar uma solução peso pesado também, mas falhava por alguns minutos em algumas sobreposições.

Ab.
Estevaoba
Membro
Membro
 
Mensagens: 368
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 42 times
Have thanks: 170 times

Re: Como calcular horas extras eliminando horas sobrepostas.

Mensagempor JSCOPA » Ter Jul 10, 2018 10:38 pm

.
"No dia 14, o resultado esperado era 2:19 e você chegou em 2:32, ou seja, algumas sobreposições permaneceram" ...
.
Talvez vc viu minhas postagem antes de eu editar!! ... Testa de novo!! ... Dá 2:19 sim!!
.
Dia 21/03/18 a dele tá dando 2:06 ... mas o correto é 1:44
.
JSCOPA
.
Se a resposta foi útil, agradeça clicando na mãozinha!! ... Se resolveu, clique em "resolvido"!!
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 1157
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 189 times
Have thanks: 287 times

Próximo

Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes