Retornar vencimento dia específico  [Resolvido]

Fórum para assuntos relacionados as funções de tempo do Excel, como AGORA, DATADIF, DATAM, DIATRABALHOTOTAL, etc...

Retornar vencimento dia específico

Mensagempor alberju » Dom Out 08, 2017 2:43 pm

Boa tarde pessoal,

Preciso de uma fórmula para que o cálculo do vencimento de 60 dias de uma fatura caia sempre na Segunda-Feira antecipando ou adiando.

Por exemplo:

Emissão: Vencimento:
08/10/2017 07/12/2017 (Quinta-feira)

Neste caso precisarei adiar, para que o vencimento caia no dia 11/12 (Segunda-feira)

Ou seja, se o vencimento de 60 dias cair na quinta-feira em diante jogar para a próxima segunda, mas se cair na quarta ou terça antecipar para segunda anterior.

Alguém pode me ajudar? :D
alberju
Membro
Membro
 
Mensagens: 7
Registrado em: Qua Abr 19, 2017 2:38 pm
Has thanked: 4 times
Have thanks: 0 time

{ SO_SELECT }

Share on Facebook Facebook

Re: Retornar vencimento dia específico

Mensagempor wagner » Seg Out 09, 2017 8:29 am

alberju

Bom dia!

Utilize essa fórmula:!
Código: Selecionar todos
=SE(DIA.DA.SEMANA(A2+60)=5;A2+60+4;SE(DIA.DA.SEMANA(A2+60)=6;A2+60+3;SE(DIA.DA.SEMANA(A2+60)=7;A2+60+2;SE(DIA.DA.SEMANA(A2+60)=1;A2+60+1;SE(DIA.DA.SEMANA(A2+60)=3;A2+60-1;SE(DIA.DA.SEMANA(A2+60)=4;A2+60-2;A2+60))))))
Se a resposta foi últil para você, por gentileza, Amigo,clique na mãozinha ao lado direito da sua tela. No canto superior.

Atenciosamente
Wagner Morel

For this post the author wagner thanked:
alberju (Seg Out 09, 2017 11:59 am)
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 2883
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 42 times
Have thanks: 1283 times

Re: Retornar vencimento dia específico  [Resolvido]

Mensagempor wagner » Seg Out 09, 2017 8:31 am

Na fórmula estou supondo que a Data da Fatura está em A2 e que a Data de Vencimento ficará em B2.
Se a resposta foi últil para você, por gentileza, Amigo,clique na mãozinha ao lado direito da sua tela. No canto superior.

Atenciosamente
Wagner Morel

For this post the author wagner thanked:
alberju (Seg Out 09, 2017 12:47 pm)
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 2883
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 42 times
Have thanks: 1283 times

Re: Retornar vencimento dia específico

Mensagempor alberju » Seg Out 09, 2017 12:48 pm

Cara, resolveu meu problema... vlw mesmo! :D :D :D
alberju
Membro
Membro
 
Mensagens: 7
Registrado em: Qua Abr 19, 2017 2:38 pm
Has thanked: 4 times
Have thanks: 0 time


Voltar para Datas & Horas

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante