Condição para média ponderada

Formatação condicional

Condição para média ponderada

Mensagempor tvhanto » Dom Jun 24, 2018 12:30 pm

Boa tarde!

Gostaria de um ajuda para incluir no meu resultado, o qual é média ponderada, apenas as células que apresentam informações.

Segue planilha para melhor visualização.
Você não está autorizado a ver ou baixar esse anexo.
tvhanto
Membro
Membro
 
Mensagens: 8
Registrado em: Dom Mar 04, 2018 10:52 am
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Re: Condição para média ponderada

Mensagempor wagner » Dom Jun 24, 2018 3:06 pm

tvhanto,

Boa tarde!

Fiz com a utilização de códigos VBA da seguinte forma:
- Se você fizer qualquer alteração na faixa de células C4 a E11, automaticamente, a fórmula em E12 se altera de modo a refletir apenas a última linha com dados da coluna E. Por exemplo: A fórmula que está em E12 atual é:
Código: Selecionar todos
=SOMARPRODUTO(E4:E7;C4:C7)/SOMA(C4:C7)

Digamos que você apague o valor de E7, a fórmula em E12 se ajustará para:
Código: Selecionar todos
=SOMARPRODUTO(E4:E6;C4:C6)/SOMA(C4:C6)


Veja se é assim.
Você não está autorizado a ver ou baixar esse anexo.
Se a resposta foi útil para você, por gentileza, Amigo, clique na mãozinha ao lado direito da ferramenta CITAR, no canto superior direito.

Atenciosamente
Wagner Morel
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 4125
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 69 times
Have thanks: 1790 times

Re: Condição para média ponderada

Mensagempor skulden » Qui Jul 12, 2018 2:37 pm

Boa tarde,

Basta trabalhar de forma matricial, após inserir as fórmulas pressione control + shift + enter

Para a célula D12: =SOMARPRODUTO(SE(D4:D11>0;D4:D11);SE(C4:C11>0;C4:C11))/SOMA(SE(D4:D11>0;C4:C11))

Para a célula E12:
=SOMARPRODUTO(SE(E4:E11>0;E4:E11);SE(C4:C11>0;C4:C11))/SOMA(SE(E4:E11>0;C4:C11))
Se a resposta lhe foi útil, clique no joinha!
skulden
Membro
Membro
 
Mensagens: 169
Registrado em: Ter Jul 19, 2016 8:33 pm
Has thanked: 4 times
Have thanks: 54 times


Voltar para Formatação Condicional

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante