Formartar cor com SE e E  [Resolvido]

Formatação condicional

Formartar cor com SE e E

Mensagempor TBravo » Qui Out 31, 2019 3:16 pm

Oi pessoal!

Estou colocando uma regra na formatação condicional que diz o seguinte:

se A2 = "seca" E f2>j2 deve pintar a célula.

O valor de J2 é 0:45

Valores maiores que 0:45 estão sendo pintados corretamente mas o problema é que a formula está entendendo que 0:30 também é maior que 0:45 e pintando a célula.... podem me ajudar, por favor?

Segue arquivo.

https://www.sendspace.com/file/7y6qyj
TBravo
Membro
Membro
 
Mensagens: 151
Registrado em: Qua Jan 21, 2015 9:24 am
Has thanked: 66 times
Have thanks: 3 times

{ SO_SELECT }

Re: Formartar cor com SE e E

Mensagempor JSCOPA10 » Qui Out 31, 2019 3:31 pm

.
A coluna F está com formatação errada, onde você vê 00:35 na verdade é 72:35 ... formata a coluna F para ... [h]:mm ... e verá que todas as horas são maiores que 00:45 ... já que você está somando também a diferença de datas (colunas D e E) !!
.

For this post the author JSCOPA10 thanked:
TBravo (Qui Out 31, 2019 4:09 pm)
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 203
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 20 times
Have thanks: 65 times

Re: Formartar cor com SE e E

Mensagempor TBravo » Qui Out 31, 2019 4:08 pm

Entendi JSCOPA10....

Nesse caso eu não consigo então fazer uma formatação condicional com esta regra?

Eu utilizei este cálculo com as data também porque não sei outra forma. Para conseguir trazer a duração de uma atividade como por exemplo início às 23:00hs e término às 2:00 da manhã calculando apenas data fim menos data início dava um erro então encontrei esta solução pesquisando na internet.
TBravo
Membro
Membro
 
Mensagens: 151
Registrado em: Qua Jan 21, 2015 9:24 am
Has thanked: 66 times
Have thanks: 3 times

Re: Formartar cor com SE e E

Mensagempor TBravo » Qui Out 31, 2019 4:11 pm

Acabei de perceber que também não vou conseguir somar ou fazer média com esta formatação né.... :(
TBravo
Membro
Membro
 
Mensagens: 151
Registrado em: Qua Jan 21, 2015 9:24 am
Has thanked: 66 times
Have thanks: 3 times

Re: Formartar cor com SE e E  [Resolvido]

Mensagempor JSCOPA10 » Qui Out 31, 2019 4:16 pm

.
Teste esta formula na coluna F ... =SEERRO(MOD(C2-B2;1);0)
.
PS: considerei que as horas das colunas C e D são sempre menores que 24h ... ou seja, que nunca começa 10h de segunda e termina às 10h de quarta!!!
.
Avatar do usuário
JSCOPA10
Ninja do Excel
Ninja do Excel
 
Mensagens: 203
Registrado em: Qua Jun 19, 2019 9:11 pm
Has thanked: 20 times
Have thanks: 65 times

Re: Formartar cor com SE e E

Mensagempor TBravo » Qui Out 31, 2019 4:45 pm

Deu certo.... muuuuito obrigada!!!! :D :D :D
TBravo
Membro
Membro
 
Mensagens: 151
Registrado em: Qua Jan 21, 2015 9:24 am
Has thanked: 66 times
Have thanks: 3 times


Voltar para Formatação Condicional

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 3 visitantes