Verificar se um Número é Inteiro ou Não.  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Verificar se um Número é Inteiro ou Não.

Mensagempor marcinhovn » 21 Jan 2013, 15:32

Boa Tarde

Estou com uma dúvida que talvez seja mais simples de resolver do que eu imagine, porém não estou conseguindo.
Na célula A1 tenho o valor "1,27" digitado.
Na célula C1, quero uma função que me diga se o valor em A1 é inteiro ou não, ou seja, se for "1,00" ou "2,00" é inteiro, mas neste caso como o valor digitado é "1,27", então ele não é um número inteiro.
Além disso, se ele não for inteiro quero que me diga se o número nas casas decimais é maior do que "0,50" ou menor.

Parace um tanto estranho, mas acho que deu pra explicar.


Abraços.
marcinhovn
Membro
Membro
 
Mensagens: 16
Registrado em: 06 Dez 2012, 20:08
Agradeceu : 2 vezes
Foi agradecido: 0 time

Re: Verificar se um Número é Inteiro ou Não.

Mensagempor Reinaldo » 21 Jan 2013, 15:45

Experimente em C1=SE(A1-INT(A1)=0;"Inteiro";SE(E(A1-INT(A1)>0;A1-INT(A1)<0,5);"Não Menor";"Não Maior"))
e Tente adaptar a sua real necessidade
Avatar do usuário
Reinaldo
Expert
Expert
 
Mensagens: 2780
Registrado em: 19 Dez 2009, 10:59
Agradeceu : 87 vezes
Foi agradecido: 1149 vezes

Re: Verificar se um Número é Inteiro ou Não.  [Resolvido]

Mensagempor marcinhovn » 21 Jan 2013, 15:56

É isto aí...
Bem isso que eu precisava.

Obrigado
marcinhovn
Membro
Membro
 
Mensagens: 16
Registrado em: 06 Dez 2012, 20:08
Agradeceu : 2 vezes
Foi agradecido: 0 time

Re: Verificar se um Número é Inteiro ou Não.

Mensagempor Bernardo » 22 Jan 2013, 08:16

Bom dia,

Segue mais uma sugestão:
Código: Selecionar todos
=ÍNDICE({"Inteiro";"Não Menor";"Não Maior"};CORRESP(A1-INT(A1);{0;0,01;0,5}))


Qualquer coisa da o grito.
Abraço
Att.
Bernardo Maia
Ninja do Excel/Moderador

E-Mail: bernardo.xls@gmail.com

Imagem
Avatar do usuário
Bernardo
Ninja do Excel
Ninja do Excel
 
Mensagens: 1554
Registrado em: 06 Jul 2009, 10:20
Localização: Belo Horizonte - MG
Agradeceu : 10 vezes
Foi agradecido: 367 vezes


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Bruno83, Google [Bot], rcc e 6 visitantes