PROCH: quase conseguindo resolver.

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

PROCH: quase conseguindo resolver.

Mensagempor jalexm » Qui Nov 08, 2018 5:47 pm

Olá.
Estou tentando criar uma planilha da seguinte forma:
Código: Selecionar todos
            1   2   3
1   2   4   X   X   -
3   5   8   -   -   X

Ou seja, quando algum elemento das linhas à direita estiver presente na linha do topo da planilha, no cruzamento entre elas deve aparecer um "X", senão deve aparecer um "-".
Nas células dos cruzamentos estou usando =SE(PROCH(D$1;$A2:$C2;1;0)=D$1; "X"; "-"), mas parece que PROCH retorna algo indefinido quando não encontra um valor e o caracter "-" não aparece e sim #N/D
Estou quase conseguindo.
Alguém poderia ajudar?
Obrigado.
jalexm
Membro
Membro
 
Mensagens: 75
Registrado em: Ter Set 03, 2013 10:13 am
Has thanked: 62 times
Have thanks: 0 time

{ SO_SELECT }

Re: PROCH: quase conseguindo resolver.

Mensagempor Estevaoba » Qui Nov 08, 2018 8:51 pm

=SE(É.NÃO.DISP(CORRESP(D$1;$A2:$C2;0));"-";"X")
Estevaoba
Membro
Membro
 
Mensagens: 401
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 46 times
Have thanks: 194 times


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante