auto preenchimento e não repetição de valores  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Re: auto preenchimento e não repetição de valores  [Resolvido]

Mensagempor wagner » Qui Dez 14, 2017 3:10 pm

uilhian,

Fora isso que o fcarlos comentou (códigos 1 a 4 estavam ainda com fórmulas), após o envio para você com VBA, descobri também que a fórmula que estava na coluna A da aba CLIENTES, na verdade, estava colocando seu código como texto e não como número. Por isso o PROCV da coluna C da aba Saídas-Vendas não localizava o código.

Dessa forma, você tem agora duas soluções:
1 - Usar com VBA como lhe enviei.
2 - Alterar a fórmula da coluna A, aba CLIENTES de:
Código: Selecionar todos
=SE(B3<>"";CONT.VALORES($B$2:B3)&"";"")


Para:
Código: Selecionar todos
=SE(B3<>"";CONT.VALORES($B$2:B3);"")
Se a resposta foi últil para você, por gentileza, Amigo,clique na mãozinha ao lado direito da sua tela. No canto superior.

Atenciosamente
Wagner Morel
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 3230
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 56 times
Have thanks: 1409 times

{ SO_SELECT }

Re: auto preenchimento e não repetição de valores

Mensagempor uilhian » Qui Dez 14, 2017 3:59 pm

Wagner,
bom acabei por usar a "Segunda Opção" - simples e objetiva. :)
mas guardei o arquivo. :)
desde ja agradeço novamente.
obrigado!
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time

Anterior

Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes