Pegar valor de uma outra tabela.  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Pegar valor de uma outra tabela.  [Resolvido]

Mensagempor uilhian » Qua Dez 13, 2017 10:29 am

bom dia, tenho essa seguinte FORMULA.
Código: Selecionar todos
=SE(ÉCÉL.VAZIA($B$);"";SE(ÉERROS(PROCV($B$;'CLIENTES'!A:B;1;FALSO));"CLIENTE NÃO CADASTRADO';PROCV(COL(LIN);'CLIENTES'!A:B;4;FALSO)))

sei que esta errada, pois estava tentando criar atraves dessa que ja se encontra na planilha:
Código: Selecionar todos
=SE(ÉCÉL.VAZIA(A7);"";SE(ÉERROS(PROCV(A7;'Estoque Atual-e-Cadastro'!A:G;1;FALSO));"Produto não cadastrado";PROCV(A7;'Estoque Atual-e-Cadastro'!A:G;4;FALSO)))

o que quero é o seguinte, acrescentei mais uma "tabela chama CLIENTES" em um arquivo que ja se encontrava aqui "pronto".
nessa nova tabela "CLIENTES" tem as seguintes "colunas" | COD. Cliente | NOME | TEL. | ENDEREÇO .
e na outra tabela chamada "VENDAS" eu acrescentei uma "COLUNA" chamada "CLIENTE".
o que eu gostaria é que quando eu digitasse o código do cliente (exemplo: 01) ele me retornasse o nome do cliente no lugar do código, pegando o nome do cliente equivalente ao código cadastrado na "tabela" CLIENTES.

desde ja agradeço.
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time

{ SO_SELECT }

Re: Pegar valor de uma outra tabela.

Mensagempor xlarruda » Qua Dez 13, 2017 10:44 am

uilhian ao ler a sua dúvida ficou muito dificil para visualizar a situação. Você poderia postar o seu arquivo de preferencia com o resultado que gostaria de alcançar em destaque?

Abrç!
Att,

xlarruda.
Avatar do usuário
xlarruda
Membro
Membro
 
Mensagens: 196
Registrado em: Qua Out 04, 2017 9:41 am
Localização: Cuiabá-MT
Has thanked: 53 times
Have thanks: 56 times

Re: Pegar valor de uma outra tabela.

Mensagempor uilhian » Qua Dez 13, 2017 11:29 am

olha segue em anexo o arquivo.
o que quero é na tabela "Saida - Vendas" ao digitar o código do cliente retornar o "nome " do cliente cadastrado da tabela "CLIENTES"
Você não está autorizado a ver ou baixar esse anexo.
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time

Re: Pegar valor de uma outra tabela.

Mensagempor deciog » Qua Dez 13, 2017 11:41 am

uilhian

Desta forma que você quer é só por macro VBA, então fiz sem macro mas acrescentei uma coluna nome do cliente, sei que não é isso que desejas

Decio
Você não está autorizado a ver ou baixar esse anexo.
Espero ter ajudado.
Se foi útil, clique na mãozinha que fica do lado da ferramenta Citar.
Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Pulo - SP
Décio Gassi

For this post the author deciog thanked:
uilhian (Qua Dez 13, 2017 1:19 pm)
deciog
Membro
Membro
 
Mensagens: 601
Registrado em: Sex Out 02, 2015 2:31 pm
Has thanked: 110 times
Have thanks: 263 times

Re: Pegar valor de uma outra tabela.

Mensagempor uilhian » Qua Dez 13, 2017 1:11 pm

entendi, e pra mim colocar essa formula em toda a coluna, teria que colocar uma por uma em cada linha ?
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time

Re: Pegar valor de uma outra tabela.

Mensagempor deciog » Qua Dez 13, 2017 1:50 pm

uilhian

Tentei explicar na planilha, confere

Decio
Você não está autorizado a ver ou baixar esse anexo.
Espero ter ajudado.
Se foi útil, clique na mãozinha que fica do lado da ferramenta Citar.
Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Pulo - SP
Décio Gassi

For this post the author deciog thanked:
uilhian (Qua Dez 13, 2017 1:59 pm)
deciog
Membro
Membro
 
Mensagens: 601
Registrado em: Sex Out 02, 2015 2:31 pm
Has thanked: 110 times
Have thanks: 263 times

Re: Pegar valor de uma outra tabela.

Mensagempor uilhian » Qua Dez 13, 2017 2:00 pm

muito obrigado.
uma ultima duvida:
pra quando eu colocar um código "inexistente" aparece "Cliente Não Cadastrado" .
Código: Selecionar todos
=SE(B6>0;PROCV(B6;CLIENTES!$A$2:$B$24;2;0);"")
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time

Re: Pegar valor de uma outra tabela.

Mensagempor deciog » Qui Dez 14, 2017 6:53 am

uilhian, Bom Dia.

Segue formula caso não tenha o código

=SE(B3>0;SEERRO(PROCV(B3;CLIENTES!$A$2:$B$24;2;0);"");"")

Decio
Espero ter ajudado.
Se foi útil, clique na mãozinha que fica do lado da ferramenta Citar.
Marque o tópico como Resolvido se foi solucionado seu problema.
Brasil, São Pulo - SP
Décio Gassi

For this post the author deciog thanked:
uilhian (Qui Dez 14, 2017 10:28 am)
deciog
Membro
Membro
 
Mensagens: 601
Registrado em: Sex Out 02, 2015 2:31 pm
Has thanked: 110 times
Have thanks: 263 times

Re: Pegar valor de uma outra tabela.

Mensagempor uilhian » Qui Dez 14, 2017 10:31 am

muito obrigado pela força.
uilhian
Membro
Membro
 
Mensagens: 13
Registrado em: Qua Dez 13, 2017 10:19 am
Has thanked: 5 times
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Patropi e 1 visitante