PROCV utilizando duas colunas no núm_índice_coluna  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

PROCV utilizando duas colunas no núm_índice_coluna  [Resolvido]

Mensagempor rafasg » Ter Nov 14, 2017 2:13 pm

Boa tarde pessoal,

Tenho em uma planilha os dados dos produtos vendidos pela empresa, como:
1 2 3 4 5
cód | descricao | texto compl. | unidade | valor
01 teste ok pc 1,00

Em outra planilha temos o pedido, onde o vendedor digita o cód. do produto e através da função PROCV puxo os dados relativos.
Como a coluna "texto compl." possui uma descrição mais detalhada, os usuários querem que coloque esse campo "texto compl." ao lado da descrição.
Exemplo:

=PROCV(F4;Lista!A2:F1000;2 e 3;0)
resultado: teste ok

Existe essa possibilidade utilizando essa função?
rafasg
Membro
Membro
 
Mensagens: 2
Registrado em: Ter Nov 14, 2017 2:00 pm
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Re: PROCV utilizando duas colunas no núm_índice_coluna

Mensagempor wagner » Ter Nov 14, 2017 2:20 pm

rafasg,

Boa tarde!

Pode até ser que exista essa possibilidade com a função PROCV (eu desconheço). Todavia, existem muitos usuários "feras" em Excel nesse fórum e com certeza eles apresentarão uma solução para o problema. Essa solução, poderá ser bem rápida se você anexar, aqui mesmo no fórum, seu arquivo compactado com .ZIP, mostrando, inclusive, como deve ser o resultado esperado.
Se a resposta foi últil para você, por gentileza, Amigo,clique na mãozinha ao lado direito da sua tela. No canto superior.

Atenciosamente
Wagner Morel
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 3027
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 43 times
Have thanks: 1331 times

Re: PROCV utilizando duas colunas no núm_índice_coluna

Mensagempor wzxnet7 » Ter Nov 14, 2017 2:20 pm

Boa tarde.
Se eu entendi direito o seguinte deve ser suficiente:
Código: Selecionar todos
=PROCV(F4;Lista!A2:F1000;2;0) & " " & PROCV(F4;Lista!A2:F1000;3;0)
Resposta útil? Clique na mãozinha ao lado do botão Citar.

For this post the author wzxnet7 thanked:
RafaelG (Dom Nov 19, 2017 3:59 pm)
Avatar do usuário
wzxnet7
Membro
Membro
 
Mensagens: 393
Registrado em: Qui Jul 21, 2016 10:26 am
Has thanked: 21 times
Have thanks: 179 times

Re: PROCV utilizando duas colunas no núm_índice_coluna

Mensagempor skulden » Ter Nov 14, 2017 2:25 pm

Por que você não atribui uma célula para cada solicitação? Em uma célula você puxa os dados referentes a segunda coluna e na célula ao lado você puxa os dados referentes a terceira coluna.

A estrutura da tabela de consulta possuiria três colunas: cod | descricao | texto compl.

Agora, se você realmente deseja juntar os dois resultados, pode trabalhar com concatenação e ai sua fórmula iria ficar da seguinte forma:
Código: Selecionar todos
=PROCV(F4;Lista!A2:F1000;2;0)&" - "&PROCV(F4;Lista!A2:F1000;3;0)



Abraços.
Se a resposta lhe foi útil, clique no joinha!
skulden
Membro
Membro
 
Mensagens: 144
Registrado em: Ter Jul 19, 2016 8:33 pm
Has thanked: 4 times
Have thanks: 39 times

Re: PROCV utilizando duas colunas no núm_índice_coluna

Mensagempor xlarruda » Ter Nov 14, 2017 3:01 pm

rafasg não sei se eu entendi mas dá uma olhadinha nessa planilha e tente adaptar na sua situação.

Obs* Por ser matricial a fórmula deverá ser finalizada com Crlt + Shift + ENTER

Abrç!
Você não está autorizado a ver ou baixar esse anexo.
Att,

xlarruda.
Avatar do usuário
xlarruda
Membro
Membro
 
Mensagens: 90
Registrado em: Qua Out 04, 2017 9:41 am
Localização: Cuiabá-MT
Has thanked: 38 times
Have thanks: 14 times

Re: PROCV utilizando duas colunas no núm_índice_coluna

Mensagempor rafasg » Ter Nov 14, 2017 3:13 pm

Obrigado pela ajuda pessoal. Funcionou.
rafasg
Membro
Membro
 
Mensagens: 2
Registrado em: Ter Nov 14, 2017 2:00 pm
Has thanked: 0 time
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Google [Bot] e 3 visitantes

cron