PROCV Imagem

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

PROCV Imagem

Mensagempor Ysa Oliver » Sex Dez 04, 2015 7:11 am

Bom dia!

Estou tentando criar uma planilha em que o usuário entre com um valor e a célula retorne uma imagem correspondente.

Utilizei a função =ÍNDICE(FMEA!$AK$14:$AK$16;CORRESP(FMEA!$K$14;FMEA!$AJ$14:$AJ$16);0) ( em formulas - nome) e associei a imagem.

O ponto é preciso que esta mesma formula seja aplicada ao longo da coluna inteira ( mais ou menos 140 linhas) e cada linha altere a sua imagem de forma independente. Através dessa formula se eu alterar o valor da celula K14 ele altera a k15 k16 k17 etc... a unica forma que consegui foi criando um "nome" para cada imagem de cada linha alterando a formula para cada célula, no entanto isso fica inviavel visto que a minha planilha possui 140 linhas.


Como faço para que a formula fique "genérica" ( ou que o excel reconheça que cada linha vai ter uma imagem e cada imagem deve ser alterada com o valor inserido na linha)?

Existe alguma forma de fazer isso?

Obrigada!

Ysa :D
Ysa Oliver
Membro
Membro
 
Mensagens: 1
Registrado em: Sex Dez 04, 2015 7:02 am
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Re: PROCV Imagem

Mensagempor setti » Ter Mar 01, 2016 6:44 pm

$colunalinhainicial:$coluna$linhafinal
setti
Membro
Membro
 
Mensagens: 150
Registrado em: Sáb Mar 28, 2015 10:35 am
Has thanked: 21 times
Have thanks: 18 times

Re: PROCV Imagem

Mensagempor rilust » Qui Mar 03, 2016 7:21 pm

prezado

achei uma planilha que deve ter ajudar
Você não está autorizado a ver ou baixar esse anexo.
Espero ter Ajudado.
Por favor não se esqueça:
Se a mensagem foi util Favor Clicar na mãozinha ao lado de citar
Se resolveu coloque como resolvido

For this post the author rilust thanked:
galox (Sáb Mar 05, 2016 11:22 pm)
rilust
Membro
Membro
 
Mensagens: 411
Registrado em: Ter Jun 16, 2015 5:23 pm
Has thanked: 91 times
Have thanks: 157 times

Re: PROCV Imagem

Mensagempor gtsalikis » Sex Mar 04, 2016 1:36 am

Você travou a célula com cifrão $

Na tua fórmula está assim: $K$14

Deixe assim: K14

Ou seja:
=ÍNDICE(FMEA!$AK$14:$AK$16;CORRESP(FMEA!K14;FMEA!$AJ$14:$AJ$16);0)

Depois arraste.

Abs
Lembre-se de AGRADECER Imagem aos que te ajudaram, e de marcar o tópico como [Resolvido] Imagem

 Gilmar
Imagemmember

For this post the author gtsalikis thanked:
rilust (Sex Mar 04, 2016 9:58 am)
gtsalikis
Ninja do Excel
Ninja do Excel
 
Mensagens: 2441
Registrado em: Sex Out 12, 2012 3:26 pm
Has thanked: 52 times
Have thanks: 1214 times


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante