Como verificar 2 ou mais critérios ao mesmo tempo em 1matriz  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Como verificar 2 ou mais critérios ao mesmo tempo em 1matriz

Mensagempor ArthurS » Qui Out 12, 2017 3:13 pm

Boa noite!

Pessoal tentei fazer uma fórmula usando o “se”, porem cheguei ao limite dela. Gostaria de saber se tem alguma outra forma de fazer.
Minha dificuldade é o seguinte:
Tenho 2 valores que irei digitar e a formula tem que procurar na matriz, um valor igual ou superior ao primeiro coluna D e menor ou igual ao valor da coluna E e retornar o valor da coluna C.

Sei que ficou bem embolado por isso irei postar a planilha e exemplificar:
Valores para busca na coluna I e J para retornar a resposta na coluna K
I J K
Vazão Altura Resultado
0,63 1,5

Busca
Imagem

Depois da busca aparece na coluna k “Aa2” pois apesar da Aa1 atender o primeiro critério não atende o segundo.
Obrigado!
Você não está autorizado a ver ou baixar esse anexo.
ArthurS
Membro
Membro
 
Mensagens: 25
Registrado em: Seg Out 09, 2017 9:58 am
Has thanked: 4 times
Have thanks: 1 time

{ SO_SELECT }

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor Estevaoba » Qui Out 12, 2017 4:20 pm

Boa tarde.

Tente desta forma;

Código: Selecionar todos
=ÍNDICE($C$2:$C$40;MÍNIMO(SE($D$2:$D$40>=$I6;SE($E$2:$E$40<=$J6;LIN($C$2:$C$40)-1))))


Fórmula matricial. Cole e tecle ctrl+shift+enter simultaneamente.

Good luck!

For this post the author Estevaoba thanked:
ArthurS (Qui Out 12, 2017 8:47 pm)
Estevaoba
Membro
Membro
 
Mensagens: 240
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 31 times
Have thanks: 107 times

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor JSCOPA » Qui Out 12, 2017 6:51 pm

.
Não entendi bem a pergunta, e muito menos o exemplo (porque 0,63 e 1,5 deveria retornar As2?????)!! ...
.
O 0,63 não igual ou superior a nenhum valor da coluna D, logo não teria resposta (??)!!!
.
Mesmo vendo a sugestão do Estevaoba, não encontrei lógica!!! ...
.
JSCOPA
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 950
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 165 times
Have thanks: 210 times

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor ArthurS » Qui Out 12, 2017 8:47 pm

JSCOPA vc não deve ter intendido, o número da coluna tem que ser maior ou igual, ou seja 0,63 tem que ser menor, logo logica é inversa também para a próxima coluna.

O amigo Estevaoba entendeu a minha necessidade baseado no meu exemplo, por isso achei mais fácil exemplificar do que simplesmente só escrever.
Mesmo assim minha resposta na mão olhando rápido foi errada, pois isso queria uma formula, e valor correto é DC1 .

porem ao rodar a formula ela deu errado. quando a formula não acha um valor ela retorna o primeiro valor encontrado.

teria como colocar uma obs do gênero "Verificar" se não achar o valor.

exemplo :
Vazão Altura
41,57 1,00

ou

Vazão Altura
20,57 0,80


Retornou o primeiro valor "aa1" da tabela que não corresponde ao real, este valor não existe na tabela procurar. referia dar erro ou alguma obs.

Obrigado!
ArthurS
Membro
Membro
 
Mensagens: 25
Registrado em: Seg Out 09, 2017 9:58 am
Has thanked: 4 times
Have thanks: 1 time

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor ArthurS » Sex Out 13, 2017 4:05 pm

outro erro que está dando
Vazão Altura
6,02 2,50

está retornando "as1,3" quando deveria "af1,6"
ArthurS
Membro
Membro
 
Mensagens: 25
Registrado em: Seg Out 09, 2017 9:58 am
Has thanked: 4 times
Have thanks: 1 time

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma  [Resolvido]

Mensagempor ArthurS » Sex Out 13, 2017 8:04 pm

Galera para quem precisar algum dia.
acho que resolvi.

Código: Selecionar todos
=SEERRO(ÍNDICE($D$2:$D$40;MENOR(SE($E$2:$E$40>=$J6;SE($F$2:$F$40<=K6;LIN($D$2:$D$40)-1));1));"ver")


se eu encontrar algum outro erro eu aviso..
ArthurS
Membro
Membro
 
Mensagens: 25
Registrado em: Seg Out 09, 2017 9:58 am
Has thanked: 4 times
Have thanks: 1 time

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor JSCOPA » Sex Out 13, 2017 9:24 pm

.
Arthurs, mais uma vez não consigo entender seu problema k ... desculpe, não sei resolver, mas as soluções estão sendo contraditórias!!
.
Você disse: 6,02 e 2,50 deveria retornar "af1,6" ... e sua solução retorna as1,2 ... e mesmo assim você deu como resolvido !!!
.
De qualquer forma, é só um comentário, se seu problema foi resolvido, ótimo!!
.
JSCOPA
Avatar do usuário
JSCOPA
Membro
Membro
 
Mensagens: 950
Registrado em: Sáb Jul 04, 2009 7:54 pm
Has thanked: 165 times
Have thanks: 210 times

Re: Como verificar 2 ou mais critérios ao mesmo tempo em 1ma

Mensagempor ArthurS » Seg Out 16, 2017 9:10 am

JSCOPA por isso, sim 6,02 e 2,50, mais uma vez vi errado, af1,5 atende os critérios antes do af1,6... pois 6,02=<8,45 e 2,50>=2,50 .. e não sei porque quando testei a formula do amigo de cima estava me retornando alguns valores errados...
Sim o fórum me ajudou a fuscar mais da fórmula ÍNDICE, e através dela consegui montar o que eu precisava.
abraço.
ArthurS
Membro
Membro
 
Mensagens: 25
Registrado em: Seg Out 09, 2017 9:58 am
Has thanked: 4 times
Have thanks: 1 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 5 visitantes