Matrizes subsequentes automáticas  [Resolvido]

Fórmulas básicas e avançadas do Microsoft Excel, Fórmulas Matriciais, Fórmulas combinadas, Funções como PROCV, PROCH, SOMASE, SOMA, SE, etc.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Matrizes subsequentes automáticas

Mensagempor AugustoC » Ter Ago 01, 2017 11:39 am

Bom dia pessoal!
Estou precisando muito da ajuda de vocês.
Tenho um banco de dados enorme, e preciso, dentro dele, calcular a média de uma sequência valores na coluna C, em função de um registro que surge esporadicamente na coluna B.
Basicamente queria uma função que reconhecesse as matrizes na coluna C, e retornasse o valor da média em uma célula da coluna D.
Segue uma planilha como exemplo.
Você não está autorizado a ver ou baixar esse anexo.
AugustoC
Membro
Membro
 
Mensagens: 5
Registrado em: Qui Ago 27, 2015 7:59 pm
Has thanked: 0 time
Have thanks: 0 time

{ SO_SELECT }

Share on Facebook Facebook

Re: Matrizes subsequentes automáticas

Mensagempor wagner » Ter Ago 01, 2017 11:57 am

Augusto,

Bom dia!

Porque no exemplo que você enviou, no cálculo da segunda média (célula D10 = 42) você não considera o valor da célula C6? Porque somente de C7 a C10?
Se a resposta foi últil para você, por gentileza, Amigo,clique na mãozinha ao lado direito da sua tela. No canto superior.

Atenciosamente
Wagner Morel
Avatar do usuário
wagner
Moderador
Moderador
 
Mensagens: 2678
Registrado em: Sáb Out 20, 2012 12:49 pm
Localização: Fortaleza - CE
Has thanked: 34 times
Have thanks: 1196 times

Re: Matrizes subsequentes automáticas

Mensagempor Estevaoba » Qua Ago 02, 2017 11:45 am

Bom dia, AugustoC.

Tente esta fórmula matricial em D2. Cole e pressione simultaneamente ctrl+shift+enter e copie para preencher a coluna:

Código: Selecionar todos
=SE(B2="";"";MÉDIA(DESLOC(C2;;;-LINS($C$2:$C2)+SEERRO(MENOR(SE($B$2:$B2<>"";LIN($B$2:$B2)-1);CONT.SE($B$2:$B2;">0")-1);0);1)))


Good luck!
Estevaoba
Membro
Membro
 
Mensagens: 145
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 23 times
Have thanks: 64 times

Re: Matrizes subsequentes automáticas

Mensagempor AugustoC » Qui Ago 10, 2017 9:52 pm

Desculpa Wagner, acabei me enganando na hora de criar o exemplo.
Obrigado pela prontidão.
Editado pela última vez por Patropi em Qui Ago 10, 2017 10:03 pm, em um total de 1 vez.
Razão: Use o botão Responder - Só use o botão citar quando realmente for necessário.
AugustoC
Membro
Membro
 
Mensagens: 5
Registrado em: Qui Ago 27, 2015 7:59 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Matrizes subsequentes automáticas

Mensagempor AugustoC » Qui Ago 10, 2017 9:53 pm

Estevaoba

Amigo, era EXATAMENTE disto que eu estava falando!
Você economizou horas do meu trabalho.
Muito obrigado pela ajuda!
Editado pela última vez por Patropi em Qui Ago 10, 2017 10:03 pm, em um total de 1 vez.
Razão: Use o botão Responder - Só use o botão citar quando realmente for necessário.
AugustoC
Membro
Membro
 
Mensagens: 5
Registrado em: Qui Ago 27, 2015 7:59 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Matrizes subsequentes automáticas

Mensagempor Patropi » Sex Ago 11, 2017 10:32 pm

Tópico destrancado por solicitação do autor.

[]s

Patropi- Moderador
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 7925
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 176 times
Have thanks: 3052 times

Re: Matrizes subsequentes automáticas

Mensagempor AugustoC » Dom Ago 13, 2017 5:05 pm

Estevaoda, boa tarde.
Como havia conversado com você, peço-lhe desculpa pelo meu erro.
A sua fórmula está corretíssima e atenderia à minha solicitação se eu não tivesse explicado errado.
Segue a planilha com o exemplo correto.
Você verá que é só um ajuste simples, que você conseguirá fazer sem dificuldade, considerando seu alto nível de conhecimento no Excel.
Antecipadamente grato.
Você não está autorizado a ver ou baixar esse anexo.
Editado pela última vez por Patropi em Sex Ago 18, 2017 10:02 pm, em um total de 1 vez.
Razão: Use o botão Responder - Só use o botão citar quando realmente for necessário.
AugustoC
Membro
Membro
 
Mensagens: 5
Registrado em: Qui Ago 27, 2015 7:59 pm
Has thanked: 0 time
Have thanks: 0 time

Re: Matrizes subsequentes automáticas  [Resolvido]

Mensagempor Estevaoba » Ter Ago 15, 2017 10:38 am

Bom dia, AugustoC.

Tente esta fórmula matricial (ctrl+shift+enter) em D2:

Código: Selecionar todos
=SE(B2="";"";SEERRO(MÉDIA(DESLOC(C2;;;MENOR(SE($B$2:$B$1000<>"";LIN($B$2:$B$1000));CONT.SE(B$2:B2;">0")+1)-MENOR(SE($B$2:$B$1000<>"";LIN($B$2:$B$1000));CONT.SE(B$2:B2;">0"));1));""))


Na função DESLOC, a única variável é a altura, que eu vario através das funções LIN, para identificar a linha dos valores na coluna B, MENOR e CONT.SE, para ranquear esses valores de linha.
O único inconveniente ocorre na média do último valor, pois a fórmula busca uma linha com valor na coluna B, mas não encontra mais, pois a tabela já chegou no final.
Eu até conseguiria contornar esse problema, mas a fórmula ficaria muito pesada.
Mas creio que mesmo assim vai poder atender mais de 99% da sua necessidade.

Good luck!
Estevaoba
Membro
Membro
 
Mensagens: 145
Registrado em: Sex Mar 24, 2017 5:11 pm
Has thanked: 23 times
Have thanks: 64 times

Re: Matrizes subsequentes automáticas

Mensagempor AugustoC » Sex Ago 18, 2017 2:47 pm

Estevaoba, deu certo!
Era exatamente isso!
Você nem imagina o quanto me ajudou.
Obrigado.
Editado pela última vez por Patropi em Sex Ago 18, 2017 10:01 pm, em um total de 1 vez.
Razão: Use o botão Responder - Só use o botão citar quando realmente for necessário - Em respostas em sequência então, só serve para poluir o fórum.
AugustoC
Membro
Membro
 
Mensagens: 5
Registrado em: Qui Ago 27, 2015 7:59 pm
Has thanked: 0 time
Have thanks: 0 time


Voltar para Fórmulas & Funções Microsoft Excel

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante