Grafico fica diferente com formula na celula  [Resolvido]

Tudo sobre Gráficos, desde o mais simples até o mais complexo!

Grafico fica diferente com formula na celula

Mensagempor vonzuben » Qui Mai 03, 2018 7:35 pm

1 - Primeiro gráfico tem formula na coluna C, assim a linha vai até 12 no gráfico, mesmo não ter preenchido toda a coluna C da tabela ( Linha do gráfico vai até os 12 meses mesmo sem preencher toda a coluna )

2 - Já o segundo gráfico está sem formula na coluna C, assim a linha vai somente o que foi preenchido na coluna C ( Linha do gráfico vai até o mês de junho )

Como deixar com formula e com gráfico igual do item 2 acima ?

https://www.sendspace.com/file/o6nsb3

Obrigado !
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

{ SO_SELECT }

Re: Grafico fica diferente com formula na celula

Mensagempor edcronos2 » Qui Mai 03, 2018 7:59 pm

mudando essas opções

kkk formatar os arquivos para 50k está tenso
Você não está autorizado a ver ou baixar esse anexo.

For this post the author edcronos2 thanked:
vonzuben (Sex Mai 04, 2018 9:58 pm)
edcronos2
Membro
Membro
 
Mensagens: 386
Registrado em: Seg Nov 30, 2015 6:59 pm
Has thanked: 22 times
Have thanks: 72 times

Re: Grafico fica diferente com formula na celula

Mensagempor vonzuben » Qui Mai 03, 2018 8:20 pm

Quero deixar o gráfico de cima igual de baixo !

O que você passou deixa o gráfico igual de cima !
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

Re: Grafico fica diferente com formula na celula

Mensagempor Patropi » Sex Mai 04, 2018 8:30 am

Bom dia

Copie e cole a fórmula abaixo na célula C2 e arraste até a C13.

Código: Selecionar todos
=SE(B2="";NÃO.DISP();B2)


Se foi útil, clique na mãozinha.

[]s
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.

For this post the author Patropi thanked:
vonzuben (Sex Mai 04, 2018 9:58 pm)
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 8796
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 214 times
Have thanks: 3484 times

Re: Grafico fica diferente com formula na celula

Mensagempor vonzuben » Sex Mai 04, 2018 11:26 am

Patropi, quando a celula da coluna B está vazia, celula da coluna C fica com #N/D

Como posso resolver isso ?

Pois tentei isso, mas colando isso " ", gráfico volta ficar como estava

Código: Selecionar todos
=SEERRO(SE(B3="";NÃO.DISP();B3+C2);"")
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

Re: Grafico fica diferente com formula na celula

Mensagempor Patropi » Sex Mai 04, 2018 4:46 pm

Vonzuben

O que faz com que o gráfico fique correto é o #N/D.

O que você pode fazer, é esconder o erro usando formatação condicional

[]s
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.

For this post the author Patropi thanked:
vonzuben (Sex Mai 04, 2018 9:58 pm)
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 8796
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 214 times
Have thanks: 3484 times

Re: Grafico fica diferente com formula na celula

Mensagempor vonzuben » Sex Mai 04, 2018 4:58 pm

Qualquer coisa que colocar tipo 0 ou - vai alterar o gráfico

pensei em fazer em VBA, até abri um post em vba
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time

Re: Grafico fica diferente com formula na celula  [Resolvido]

Mensagempor Patropi » Sex Mai 04, 2018 5:00 pm

E só usar formatação Condicional, muito fácil e eficiente.

[]s
Patropi /Moderador
Se a resposta foi útil, clique na mãozinha ao lado da ferramenta Citar.

For this post the author Patropi thanked:
vonzuben (Sex Mai 04, 2018 9:58 pm)
Avatar do usuário
Patropi
Ninja do Excel
Ninja do Excel
 
Mensagens: 8796
Registrado em: Sáb Jun 05, 2010 4:36 pm
Localização: Campo Mourão - PR
Has thanked: 214 times
Have thanks: 3484 times

Re: Grafico fica diferente com formula na celula

Mensagempor vonzuben » Sex Mai 04, 2018 10:00 pm

Deu certo pelo condicional e até abri uma solução pelo VBA que também ficou bom !

Obrigado !
vonzuben
Membro
Membro
 
Mensagens: 536
Registrado em: Qua Fev 12, 2014 6:00 pm
Has thanked: 233 times
Have thanks: 0 time


Voltar para Gráficos

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 2 visitantes