Funções aninhadas em VBA

Visual Basic for Aplication e macros no Excel.
Regras do fórum
Sua dúvida foi respondida? Marque como RESOLVIDO em seus tópicos, usando o botão com marca verde. Imagem

Funções aninhadas em VBA

Mensagempor Nill2013Br » Ter Mar 13, 2018 4:13 pm

Gostaria de saber se alguém pode me ajudar com esta situação:

Esta fórmula compara os dados de uma célula da Plan 1 com uma coluna na Plan2: =SE(C3="";"";SEERRO(SE(PROCV(C3;'Plan2'!B$2:B$202;1;0);"SIM");"NÃO")), encontrando o valor na Plan 2 ela retorna SIM na Plan1 e não encontrando retorna NÃO. Existe alguma forma de colocar isto para ser executado em uma macro? Agradeço a ajuda.
Nill2013Br
Membro
Membro
 
Mensagens: 20
Registrado em: Dom Ago 28, 2016 11:37 pm
Has thanked: 4 times
Have thanks: 0 time

{ SO_SELECT }

Re: Funções aninhadas em VBA

Mensagempor MPrudencio » Ter Mar 13, 2018 10:30 pm

É so fazer um loop na coluna B que funciona facil.
Marcelo Prudencio
Microsoft Excel Brasil no Facebook

"Começar já é a metade do caminho."
Autor Desconhecido

Simplifica que simples fica.
Nicole Tomazella.

"O Simples é Sempre Melhor Que o Complicado"
Jorge Paulo Lemann.

MPrudencio
Membro
Membro
 
Mensagens: 2702
Registrado em: Sáb Ago 15, 2015 8:29 pm
Has thanked: 70 times
Have thanks: 592 times

Re: Funções aninhadas em VBA

Mensagempor Mauro Coutinho » Qua Mar 14, 2018 8:47 am

Na falta de mais detalhes, segue a forma básica conforme a linha da sua formula.

Código: Selecionar todos
Sub VLookup_C3()
    Dim vrNum As String

    On Error Resume Next
    vrNum = CDbl(Range("C3").Value)
   
    vr1 = Application.WorksheetFunction.VLookup(CDbl(vrNum), Worksheets("Plan2").Range("B2:B202"), 1, 0)

    If vr1 = "" Then
        Range("C3").Offset(0, 1) = "NÃO"
    Else
        Range("C3").Offset(0, 1) = "SIM"
    End If
   
End Sub


[]s
Mauro Coutinho - Moderador
São José dos Pinhais-Pr


Se a resposta foi últil para você, por gentileza, clique na mãozinha ao lado direito da sua tela. No canto superior.
Avatar do usuário
Mauro Coutinho
Ninja do Excel
Ninja do Excel
 
Mensagens: 3934
Registrado em: Sex Mar 26, 2010 9:24 pm
Localização: São José dos Pinhais - Pr
Has thanked: 181 times
Have thanks: 1447 times

Re: Funções aninhadas em VBA

Mensagempor Nill2013Br » Qui Mar 15, 2018 8:44 pm

Obrigado pela ajuda, irei testar para ver como se comporta.
Nill2013Br
Membro
Membro
 
Mensagens: 20
Registrado em: Dom Ago 28, 2016 11:37 pm
Has thanked: 4 times
Have thanks: 0 time


Voltar para VBA & Macros

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante