Pesquisa resultou em 4139 ocorrências

Voltar à pesquisa avançada

Re: Nome de Foto inserida no excel

A rotina abaixo, originariamente no site Ozgrid.com; executa o que deseja,mas deve ser adaptada a sua realidade Private Sub GetShapePropertiesAllWs() Dim sShapes As Shape, lLoop As Long Dim WsNew As Worksheet Dim wsLoop As Worksheet '''''''''''''''''''''''''''''''''''''''''''''''' ''''''''''LIST PRO...
por Reinaldo
Qui Jun 14, 2018 8:34 am
 
Fórum: VBA & Macros
Tópico: Nome de Foto inserida no excel
Respostas: 2
Exibições: 41

Re: Visualização de imagem vinculada a planilha.  [Resolvido]

Em sua planilha há um controle de formulário nomeado como Label1, e esse controle que simula o "mouse move" já que esse movimento "não existe" no Excel.
Esse controle está "ancorado" de A4 até A12; aumente essa altura, e teste.
por Reinaldo
Sex Jun 01, 2018 9:08 am
 
Fórum: VBA & Macros
Tópico: Visualização de imagem vinculada a planilha.
Respostas: 7
Exibições: 104

Re: COMPARAÇÃO DE HORAS EM UM PLANILHA  [Resolvido]

Isso deve-se a maneira de como são "guardadas" as informações de horas no Excel, uma fração das 24 hs diarias. Uma maneira de contornar é: =SE(ARRED(J5;5)<>ARRED(L5;5);"Diferente";"=") ou ainda =SE(TEXTO(J5;"[h]:mm:ss")<>TEXTO(L5;"[h]:mm:ss");"D...
por Reinaldo
Qui Mai 31, 2018 10:41 am
 
Fórum: Excel - O básico
Tópico: COMPARAÇÃO DE HORAS EM UM PLANILHA
Respostas: 2
Exibições: 57

Re: Nº QUE MUDA SOZINHO

Voce se deparou com um a limitação do Excel, "trabalha" com numeros até 15posição, apos substitui por zero (viewtopic.php?f=20&t=17583&hilit=+limitação)
Uma solução e a proposta do colega Arruda
por Reinaldo
Seg Mai 28, 2018 4:42 pm
 
Fórum: Fórmulas & Funções Microsoft Excel
Tópico: Nº QUE MUDA SOZINHO
Respostas: 2
Exibições: 43

Re: Sistema de busca  [Resolvido]

Diretamente não, será preciso montar/idealizar uma rotina de substituição e procura.
por Reinaldo
Ter Mai 22, 2018 10:23 am
 
Fórum: VBA & Macros
Tópico: Sistema de busca
Respostas: 4
Exibições: 231

Re: Erro ao criar pasta e salvar PDF dentro

Do help do Excel para o Método ExportAsFixedFormat: Filename Opcional Variant O nome do arquivo a ser salvo. Se você não incluir um caminho completo, o Excel salvará o arquivo na pasta atual Experimente assim: Sub Imprime() ' ' Imprime Macro ' Dim strPath As String, strFold As String, sPath As Strin...
por Reinaldo
Sex Mai 18, 2018 6:22 pm
 
Fórum: VBA & Macros
Tópico: Erro ao criar pasta e salvar PDF dentro
Respostas: 4
Exibições: 54

Re: Erro Query SQL - String VBA  [Resolvido]

Fica um tanto dificil tentar "ver" onde se encontra o erro, e por motivos obvios não podemos testar seu sql; sendo de uma query fica mais complicado ainda. Essa conexão (creio que ODBC) e com Access? ou outro banco. Nem sempre o erro se encontra no ponto de interrupção, muitas vezes está a...
por Reinaldo
Sex Mai 18, 2018 2:35 pm
 
Fórum: VBA & Macros
Tópico: Erro Query SQL - String VBA
Respostas: 4
Exibições: 51

Re: Fórmula pegar diferença  [Resolvido]

Sem poder ver seu modelo, visto que não estou mais inscrito no forum clubedohardware, uma possibilidade:
=SE(P3<>0;ABS(P3)-ABS(Q3); Q3)
por Reinaldo
Qua Mai 16, 2018 4:58 am
 
Fórum: VBA & Macros
Tópico: Fórmula pegar diferença
Respostas: 9
Exibições: 85

Re: Excluir linha inteira com críterio com "Do While"  [Resolvido]

Talvez assim: Sub excluir() Dim w As Worksheet Dim ultcel As Long, x As Long Set w = Sheets("NfeRelacaoRecebidas") w.Select ultcel = w.Range("C65536").End(xlUp).Row For x = ultcel To 1 Step -1 'Do While ActiveCell.Row >= 1 If Not (IsNumeric(Cells(x, 3).Value)) Then w.Rows(x &...
por Reinaldo
Sex Mai 11, 2018 11:03 am
 
Fórum: VBA & Macros
Tópico: Excluir linha inteira com críterio com "Do While"
Respostas: 4
Exibições: 70

Re: Dividindo valores zerados

Outra possibilidade; experimente:

Código: Selecionar todos
If Range("b1").Value = 0 Or IsNull(Range("B1").Value) Then
    x = 0
Else
x = Range("a1").Value / Range("b1").Value
End If
por Reinaldo
Qui Mai 10, 2018 10:39 pm
 
Fórum: VBA & Macros
Tópico: Dividindo valores zerados
Respostas: 6
Exibições: 79
Próximo

Voltar à pesquisa avançada