Função SE aninhada ...
 
Notifications
Clear all

Função SE aninhada com Procv


Bravoc
Posts: 9
Registered
Topic starter
(@bravoc)
Active Member
Entrou: 2 anos atrás

Bom dia a todos!

Eu estou tentando fazer funcionar uma fórmula e já quebrei a cabeça aqui, mas não consegui identificar onde está o erro dela.

O que preciso é testar duas condições, se elas não forem verdadeiras, então o resultado será um PROCV.

1º Condição: Verificar se o ICMS é 18%
2° Condição: Se for diferente de 18%, verifica se ele é 4%
3º Condição: Se não for nem 18%, nem 4%, pega o resulta que aparecer no PROCV

A fórmula que criei foi a seguinte:

=SE(PROCV(C5;'ICMS CLIENTES'!AG;7;0)=4%;4%;PROCV(C5;'ICMS CLIENTES'!A:B;2;0)))

Por algum motivo, a fórmula que criei não está funcionando. Creio que é um detalhe besta, mas não consegui decifrar.

Eu postei a planilha no endereço , se alguém puder, encarecidamente, dar uma olhada e me ajudar, ficarei imensamente grato.

Bom dia a todos, cordialmente,

Bravoc

 

Responder
7 Respostas
4 Respostas
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@bravoc, fica muito mais fácil fazer isso só com PROCV, sem o SE!! ... É só colocar uma tabelinha com os percentuais num canto da planilha!!

 

Como pedem as regras do fórum, e para agilizar a solução, posta um arquivo exemplo!! ... Caso contrário cada um que quiser ajudar terá que montar um arquivo!!!!!!!!!!

 

Responder
Bravoc
Registered
(@bravoc)
Entrou: 2 anos atrás

Active Member
Posts: 9

@jscopa10, me perdoe, não foi minha intenção desrespeitar as regras. 

Eu postei a planilha, mas em um site externo e coloquei o link na postagem, mas corrigindo meu erro, anexo o arquivo que está com o problema proposto.

 

Pela atenção, antecipadamente agradeço,

 

Responder
JSCOPA10
Moderator
(@jscopa10)
Entrou: 2 anos atrás

Reputable Member
Posts: 320

@bravoc, sem problemas!!
.
Não testei mas parece que a sugestão do Adalberto7 (Patropi), resolve seu problema!!! .... Mas NUNCA use formulas com coluna inteiras (A:B etc), isso só deixa o arquivo pesado, sem nenhuma necessidade, já que o Excel vai consultar 1.000.000 de células sem necessidade!! ... Se você acha que seu arquivo atingirá 1.000 linhas, dê uma boa margem, e coloque A1:B2000!! ... MAS NUNCA COLUNA INTEIRA!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

.

Responder
Bravoc
Registered
(@bravoc)
Entrou: 2 anos atrás

Active Member
Posts: 9
Postado por: @jscopa10

@bravoc, sem problemas!!
.
Não testei mas parece que a sugestão do Adalberto7 (Patropi), resolve seu problema!!! .... Mas NUNCA use formulas com coluna inteiras (A:B etc), isso só deixa o arquivo pesado, sem nenhuma necessidade, já que o Excel vai consultar 1.000.000 de células sem necessidade!! ... Se você acha que seu arquivo atingirá 1.000 linhas, dê uma boa margem, e coloque A1:B2000!! ... MAS NUNCA COLUNA INTEIRA!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

.

Muito obrigado, Jscopa10! Deus o abençoe!

Responder
Adalberto7
Posts: 106
Moderator
(@adalberto7)
Estimable Member
Entrou: 2 anos atrás

Boa tarde Bravoc

Na segunda parte da tua formula, como o PROCV não encontra aquele código do produto, retorna erro e a formula para por aí. Eu coloquei a função SEERRO para eliminar este erro.

Veja como ficou a fórmula:

=SE(PROCV(C5;'ICMSCLIENTES'!AG;7;0)=4%;4%;0);PROCV(C5;'ICMS CLIENTES'!A:B;2;0)))

Se foi útil, clique em curtir.

[]s

Responder
1 Responder
Bravoc
Registered
(@bravoc)
Entrou: 2 anos atrás

Active Member
Posts: 9
Postado por: @adalberto7

Boa tarde Bravoc

Na segunda parte da tua formula, como o PROCV não encontra aquele código do produto, retorna erro e a formula para por aí. Eu coloquei a função SEERRO para eliminar este erro.

Veja como ficou a fórmula:

=SE(PROCV(C5;'ICMSCLIENTES'!AG;7;0)=4%;4%;0);PROCV(C5;'ICMS CLIENTES'!A:B;2;0)))

Se foi útil, clique em curtir.

[]s

Perfeito!!!!! Muito obrigado, Adalberto7!! Deus o abençoe!

Responder
Adalberto7
Posts: 106
Moderator
(@adalberto7)
Estimable Member
Entrou: 2 anos atrás

@Bravoc.

Amém! Abençoe a você também!

Fico contente por ter conseguido ajudar.

[]s

Responder