Notifications
Clear all

Como contar números distintos.


mmariano
Posts: 1
Registered
Topic starter
(@mmariano)
New Member
Entrou: 3 semanas atrás

Bom dia,

Gostaria de saber como faço para contar os números distintos das prescrições de um único paciente. Qual formula seriam necessárias?

Exemplo: Paciente "1"  tem "3" prescrições distintas

Responder
5 Respostas
JordsdoExcel
Posts: 35
Registered
(@jordsdoexcel)
Eminent Member
Entrou: 2 meses atrás

Olá, amigo.

Segue solução em anexo. Montei duas soluções, fica ao seu critério escolher.

Apenas um alerta, são formulas matriciais, então caso esteja utilizando uma versão do Excel que seja de 2019 pra trás, será necessário apertar CTRL + SHIFT + ENTER para finalizar a formula e não somente o ENTER.

Abs,

Responder
JSCOPA10
Posts: 295
Moderator
(@jscopa10)
Reputable Member
Entrou: 2 anos atrás

JordsdoExcel, se colocar nomes e números repetidos não funciona!! .... Aproveitando sua planilha fiz o que entendi que ele quer (somar de acordo com nomes, mas excluindo números repetidos).

 

Mmariano, veja se é isto (tive que usar 2 colunas auxiliares) ...

Responder
JordsdoExcel
Posts: 35
Registered
(@jordsdoexcel)
Eminent Member
Entrou: 2 meses atrás

Uhum, eu sei, por isso coloquei as duas formulas, vai depender do que ele deseja fazer.

=SOMA(SE(E2=$A$2$A$7;0;1);FALSO))

Com essa formula dá certo tbm.

Eu fiquei na dúvida no que exatamente ele quer, de qualquer forma opções não faltarão pro nosso amigo hahaha.

Abs,

Responder
2 Respostas
z3020100
Registered
(@z3020100)
Entrou: 7 anos atrás

Estimable Member
Posts: 172
Postado por: @jordsdoexcel

Uhum, eu sei, por isso coloquei as duas formulas, vai depender do que ele deseja fazer.

=SOMA(SE(E2=$A$2$A$7;0;1);FALSO))

Com essa formula dá certo tbm.

Eu fiquei na dúvida no que exatamente ele quer, de qualquer forma opções não faltarão pro nosso amigo hahaha.

Abs,

Sua solução é correta.

Mas se me permite somente uma observação, acredito que neste caso a fórmula básica =somase() traria o mesmo resultado com um uso de memória menor.

Dependendo do tamanho da base de dados, o uso de fórmula matricial acaba demandando muita memória.

Abraço.

Responder
JordsdoExcel
Registered
(@jordsdoexcel)
Entrou: 2 meses atrás

Eminent Member
Posts: 35

@z3020100 É vdd hahaha Fui pelo caminho mais difícil. Você está certo.

Responder