Notifications
Clear all

Adicionar DDD e 9 digito apenas nas células onde não tem.


pedrohp
Posts: 1
Registered
Topic starter
(@pedrohp)
New Member
Entrou: 1 ano atrás

Boa tarde! 

Meus contatos de telefone são diferentes, alguns faltam o 9, e outros o DDD 

Preciso de ajuda para 2 coisas:

 

1 -Adicionar o DDD 47 em todos as células onde não tem nenhum ddd.

 

2 - Adicionar o 9 digito apenas nos números que só tenham 8 digitos.

 

Conseguem me ajudar com as fórmulas para isso?

 

Obrigado!

Responder
Tags do Tópico
1 Reply
Anderson
Posts: 182
Registered
(@anderson)
Estimable Member
Entrou: 2 anos atrás
=SE(NÚM.CARACT(A2)=9;"(47)9"&A2;SE(NÚM.CARACT(A2)=10;"(47)"&A2;SE(NÚM.CARACT(A2)=13;ESQUERDA(A2;4)&"9"&DIREITA(A2;9);SE(NÚM.CARACT(A2)=14;ESQUERDA(A2;4)&"9"&DIREITA(A2;9);SE(NÚM.CARACT(A2)=15;ESQUERDA(A2;4)&DIREITA(A2;10);A2)))))
Responder