Cálculo de diferenç...
 
Notifications
Clear all

Cálculo de diferença de datas em dias em horas úteis


DesireeMelo
Posts: 1
Registered
Topic starter
(@desireemelo)
New Member
Entrou: 2 meses atrás

Olá pessoal!
Estou fazendo um trabalho na empresa e me deparei com um problema e gostaria de uma ajuda....

Já procurei em vários fórum, mas nenhuma opção me serviu.

Estou calculando o tempo que demorou entre dois procedimentos(SLA 1) em dias e horas úteis, porém não consegui uma forma de calcular as horas úteis,

Recebimento das informação(Coluna A): 16/08/2021 1000
Envio ao convênio(Coluna C): 17/08/2021 1200
SLA1 (Coluna D): Envio ao convênio - Recebimento da informação [ no formato dd"d" hh"h" mm"min"]

Utilizei a seguinte fórmula: =SE([@[RECEBIMENTO DA INFORMAÇÃO]]="";"";SE([@[ENVIO AO CONVÊNIO]]="";$O$1-[@[RECEBIMENTO DA INFORMAÇÃO]];(DIATRABALHOTOTAL([@[RECEBIMENTO DA INFORMAÇÃO]];[@[ENVIO AO CONVÊNIO]])-MOD([@[RECEBIMENTO DA INFORMAÇÃO]];1)+MOD([@[ENVIO AO CONVÊNIO]];1))-VALOR("24:00")))
Porém a mesma não considera somente horas úteis, que seria o horário do expediente (9:00h às 18:00h)

Alguém consegue me ajudar? coloquei um anexo para melhora visualização.

Responder
1 Reply
JordsdoExcel
Posts: 71
Registered
(@jordsdoexcel)
Trusted Member
Entrou: 3 meses atrás

Olá, amiga.

Não entendi muito bem o que você quer, então segue solução para o que eu entendi.

Criei duas colunas no final da tabela, para servirem como condições.

Abs.

Responder