Notifications
Clear all

Função para somar valores mês a mês

16 Posts
2 Usuários
0 Likes
1,243 Visualizações
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

bom dia, estou tentando criar uma planilha para somar valores de vendas por cartão de crédito baseada na quantidade de parcelas mas não estou encontrando uma forma ou função que me dê os resultados. Caso alguém saiba como fazer, poderia me ajudar? Segue formato da planilha

 
Postado : 09/12/2023 10:17 am
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

@flaviogodoi Copie e cole a formula abaixo e arraste para as demais linhas da coluna: =SOMARPRODUTO((MÊS($A$3:$A$1000)=MÊS(1&L12))*($F$3:$F$1000)) Dê retorno.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 10/12/2023 4:14 pm
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

@ptropi bom dia, não funcionou. Vou mandar um print com alguns exemplos

 
Postado : 11/12/2023 9:34 am
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

Em vez de mandar print, anexe a planilha, digitando o resultado esperado na coluna Valor, demonstrando como você chegou ao resultado.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 11/12/2023 12:19 pm
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

forum não permite que eu anexe a planilha

 
Postado : 11/12/2023 5:21 pm
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

É só postar a planilha num site gratuito como SendSpace; 4shared, etc... e colocar o link da planilha aqui.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 11/12/2023 8:51 pm
(@flaviogodoi)
Posts: 9
Active Member
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

Flavio.

Eu fiz os lançamentos mensais e coloquei os totais mensais no cabeçalho de cada mês.

Confira na planilha e dê retorno.

OBS.: Zipando eu consegui anexar a planilha diretamente aqui no fórum.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 12/12/2023 1:55 pm
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

@ptropi Boa tarde, a formula funcionou corretamente na primeira linha, mas em outras não deu certo baseado na data da venda e quantidade de parcelas

 
Postado : 13/12/2023 6:00 pm
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

Segue o arquivo com outra fórmula aplicada, onde eu acrescentei uma coluna com a última data de vencimento.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 13/12/2023 7:14 pm
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

@ptropi bom dia, agora funcionou perfeitamente. Muito obrigado pelo empenho em me ajudar, valeu mesmo.

 
Postado : 14/12/2023 10:48 am
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

@ptropi boa tarde, desculpe incomodar novamente, mas quando utilizado a forma de recebimento "D" débito, os valores são preenchidos em todos os meses. Quando preenchido com "C" crédito ai sim, funciona perfeitamente. Estou quebrando a cabeça pra tentar criar uma regra mas ta difícil

 
Postado : 14/12/2023 5:51 pm
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

Eu não tive tempo de fazer testes com a letra D na planilha enviada, mas basta acrescentar mais um critério na fórmula.

Copie e cole a fórmula abaixo na célula G4, arraste para a direita e depois para baixo.

Se a resposta foi útil, clique em Curtir na mãozinha.

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 14/12/2023 6:50 pm
(@flaviogodoi)
Posts: 9
Active Member
Topic starter
 

@ptropi bom dia, não apareceu a fórmula para que eu possa copiar

 
Postado : 15/12/2023 9:04 am
P@tropi
(@ptropi)
Posts: 170
Estimable Member
 

Este fórum tem uns bugs, mas vamos lá de novo:

=SE($A4="";"";SE(E($D4="D";MÊS($B4)=MÊS(G$3);MÊS($B4)=MÊS(G$3));$F4;SE(E(G$3>=$A4;G$3<=$B4);$F4;"")))

Se a resposta foi útil, clique em curtir na mãozinha.

 
Postado : 15/12/2023 9:24 pm
Página 1 / 2