Notifications
Clear all

Subtração desconsiderando valores repetidos

6 Posts
2 Usuários
2 Likes
463 Visualizações
(@alvaro-vinicius)
Posts: 4
Active Member
Topic starter
 

Olá! estou buscando ajuda para dois problemas dentro da mesma planilha. O primeiro é o seguinte: 

Quero saber se nesta fórmula é possível usar subtotal no lugar de soma para poder filtrar e ter o total correspondente as informações filtradas: =SOMA(SE(FREQÜÊNCIA(H2:H635;H2:H635)>0;I2:I635))

 

G H I J K L
ORDEM DE VENDA VALOR OV NF ANCORA VALOR NF ANCORA SALDO TOTAL
4220887  R$   7.181,61 200600 R$ 6.317,29   R$ 4.554.725,56
4221582  R$   5.948,55 200004 R$ 5.948,55    
4221660  R$   6.587,20 200719 R$ 6.390,95    
4221742  R$   3.137,03 200827 R$ 2.830,13    
4221811  R$   7.943,38 200977 R$ 7.943,38    
4222127  R$ 18.187,12 200933 R$ 2.566,82    
4222127  R$ 18.187,12 200926 R$ 2.878,86    
4222127  R$ 18.187,12 200275 R$ 6.242,94    
4222127  R$ 18.187,12 201702 R$ 330,98    
4222127  R$ 18.187,12 201378 R$ 1.249,86    
4222127  R$ 18.187,12 201423 R$ 2.242,46    
4222127  R$ 18.187,12 202252 R$ 69,76    
4222127  R$ 18.187,12 202253 R$ 179,12    
4222127  R$ 18.187,12 202878 R$ 477,84    
4222127  R$ 18.187,12 203275 R$ 1.035,08    
4222127  R$ 18.187,12 20314 R$ 247,74    
4222127  R$ 18.187,12 204700 R$ 30,20    
4222182  R$ 11.887,86 201314 R$ 11.887,86    

O segundo caso; preciso obter na coluna K a subtração de H-J, mas observe que a partir da linha 7 o valor na coluna H se repete, pq trata-se do mesmo pedido, (coluna G).

então a subtração deve contemplar o total do valores (coluna J) compreendidos no intervalo correspondente ao mesmo pedido, (coluna G) mas considerar apenas 1x o valor na coluna H compreendido neste mesmo intervalo, uma vez que este representa o valor total de um pedido único pedido e os seus correspondentes na coluna J são retiradas desse total.
Se alguém que conseguiu entender bem e tiver uma outra alternativa que mude o modelo que mostrei mas leve ao mesmo propósito eu tbm aceito essas sugestões.

 
Postado : 28/06/2023 9:45 am
Tags do Tópico
(@alvaro-vinicius)
Posts: 4
Active Member
Topic starter
 

Alguém conseguiria ajudar, por favor?

 
Postado : 12/07/2023 10:57 am
(@osvaldomp)
Posts: 852
Prominent Member
 

Olá, Alvaro.

Para o segundo caso, se entendi corretamente, a fórmula abaixo colada em K2 e arrastada para baixo talvez lhe ajude.

=SE(CONT.SE(G$2:G2;G2)=1;H2-SOMASE(G$2:G$19;G2;J$2:J$19);"")

 

Quanto ao primeiro caso, eu sugiro que você deixe de lado por um momento a sua fórmula e explique com exatidão o cálculo que você quer fazer, informe sobre os critérios para efetuar o cálculo e informe qual é o resultado esperado para os dados que constam na sua primeira postagem acima.

Osvaldo

 
Postado : 12/07/2023 4:25 pm
(@alvaro-vinicius)
Posts: 4
Active Member
Topic starter
 

@osvaldomp Bom dia! muito obrigado por ter respondido.

Usei a fórmula que você me sugeriu mas não chegou no resultado, no lugar de subtrair ficou assim:
H I J K
4220887 R$ 7.181,61 R$ 6.317,29 R$ 3.458.048,00
4221582 R$ 5.948,55 R$ 5.948,55 R$ 3.458.676,00
4221660 R$ 6.587,20 R$ 6.390,95 R$ 3.458.749,00
4221742 R$ 3.137,03 R$ 2.830,13 R$ 3.458.822,00
4221811 R$ 7.943,38 R$ 7.943,38 R$ 3.458.875,00
4222127 R$ 18.187,12 R$ 2.566,82 -R$ 5.697.341,00
4222127 R$ 18.187,12 R$ 2.878,86
4222127 R$ 18.187,12 R$ 6.242,94
4222127 R$ 18.187,12 R$ 330,98
4222127 R$ 18.187,12 R$ 1.249,86
4222127 R$ 18.187,12 R$ 2.242,46
4222127 R$ 18.187,12 R$ 69,76
4222127 R$ 18.187,12 R$ 179,12
4222127 R$ 18.187,12 R$ 477,84
4222127 R$ 18.187,12 R$ 1.035,08
4222127 R$ 18.187,12 R$ 247,74
4222127 R$ 18.187,12 R$ 30,20
4222127 R$ 18.187,12 R$ 410,06
4222182 R$ 11.887,86 R$ 11.887,86 R$ 4.222.182,00
4222206 R$ 4.121,20 R$ 4.121,20 R$ 4.222.206,00
4222648 R$ 5.057,80 R$ 5.057,80 R$ 4.222.648,00
4222836 R$ 34.422,47 R$ 1.264,53 R$ 4.222.836,00
4222836 R$ 34.422,47 R$ 15.608,85

 
Postado : 13/07/2023 9:24 am
(@osvaldomp)
Posts: 852
Prominent Member
 

Olá, Alvaro.

Veja no arquivo anexado os resultados retornados pela fórmula que passei.

obs. prefira postar arquivos ao invés de colar os conteúdos da planilha.

Osvaldo

 
Postado : 13/07/2023 3:50 pm
(@alvaro-vinicius)
Posts: 4
Active Member
Topic starter
 

@osvaldomp Bom dia, deu certo, muito obrigado. Excelente semana para você!

 
Postado : 25/07/2023 10:05 am
Osvaldomp reacted