Notifications
Clear all

Procurar qualquer parte de um texto de uma célula em uma lista

4 Posts
2 Usuários
0 Reactions
964 Visualizações
(@alcoutinho1980)
Posts: 2
New Member
Topic starter
 

Boa Tarde Senhores.

    Preciso procurar qualquer parte de um texto em uma célula e retornar uma classificação de uma lista.

    Vou dar um exemplo bem simples:

    Tenho uma planilha com duas colunas, uma com a descrição do item e outra com a classificação do item.

    Na descrição temos dois exemplos como segue:

    TOMATE VERMELHO DA ROÇA
    PACOTE DE TOMATE AMARELO

    Nessa planilha temos uma lista com duas colunas, uma com o nome simplificado do item e outra com sua classificação, como segue no exemplo abaixo:

   TOMATE -- LEGUME

   MAÇÃO -- FRUTA

   Preciso que a classificação seja retornada baseado nessa palavra. Por exemplo, a classificação dos dois itens acima ( TOMATE VERMELHO DA ROÇA e PACOTE DE TOMATE AMARELO) deve ser LEGUME pois os dois itens contém a palavra TOMATE na célula de sua descrição.

 

   Como consigo esse resultado?

 

Obrigado!

  

 
Postado : 15/11/2022 9:55 pm
Tags do Tópico
(@osvaldomp)
Posts: 852
Prominent Member
 
Postado por: @alcoutinho1980

   Como consigo esse resultado? 

Experimente a função PROCV() com o uso de curingas ~~~> =PROCV("*TOMATE*"; ... )

Osvaldo

 
Postado : 16/11/2022 11:12 am
(@alcoutinho1980)
Posts: 2
New Member
Topic starter
 

@osvaldomp Na verdade seria o contrário. Exemplo:
Célula A1 contém: PACOTE DE TOMATE AMARELO.
Na célula B1 preciso retornar a categoria.
Na célula D1 contém: TOMATE e na célula E1 contém: LEGUMES
A fórmula que estaria na célula B1 deveria procurar o conteúdo da célula A1 na Lista D1:E1 e retornar o correspondente que está na célula E1.
Então, se for o PROCV, a lógica é o inverso. Ele vai procurar na lista o texto "PACOTE DE TOMATE AMARELO" mas na lista conterá apenas a palavra "TOMATE". Preciso que ele entenda que apenas por haver a palavra TOMATE na célula A1 ele retorne o conteúdo LEGUMES.
Não sei se ficou claro.
Obrigado.

 
Postado : 16/11/2022 11:23 am
(@osvaldomp)
Posts: 852
Prominent Member
 
Postado por: @alcoutinho1980
 
A fórmula que estaria na célula B1 deveria procurar o conteúdo da célula A1 na Lista D1:E1 e retornar o correspondente que está na célula E1.

A fórmula abaixo procura em A1 o conteúdo de D1. Se encontrado retorna E1. É o contrário do que você descreveu acima.

Se não for isso então eu sugiro que você disponibilize uma amostra do seu arquivo Excel com alguns exemplos, com o resultado esperado para cada exemplo e com as necessárias explicações na própria planilha.

=SE(ÉNÚM(LOCALIZAR(D1;A1));E1;"")

Osvaldo

 
Postado : 16/11/2022 7:24 pm