Notifications
Clear all

Um primeiro nome que mais aparece na célula  

  RSS

Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
09/04/2010 10:11 am  

Pessoal

Numa tabela tenho uma coluna que tem o nome completo de pessoas.

Tem como mostrar o primeiro nome que mais aparece numa célula?

Não é para dizer apenas a quantidade, mas quero que mostre o nome.

Assim se na coluna eu tiver 45 joão com diversos sobrenomes, ele dará a resposta joão. Primeiro lugar
daí posso escolher o segundo nome que mais aparece, o terceiro também, etc.

grato

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
28/04/2010 10:44 pm  

Via formula ate é possivel chegar no primeiro, mais no segundo acredito que so com VBA

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Fernando Fernandes
(@fernandofernandes)
Illustrious Member
Entrou: 12 anos atrás
Posts: 44273
29/04/2010 1:47 pm  

Da pra fazer assim....
se nao houve valores repetidos pode usar a seguinte formula
=ÍNDICE(A1:A50;CORRESP(MAIOR(B1:B50;D2);B1:B50;0))
lembrando q A1:A50 é a referencia dos nomes e B1:B50 dos valores

MAS....se houver nomes repetidos, tbem é possivel usando uma coluna auxiliar com a função ORDEM()!!!!
segue plan de exemplo > download/file.php?id=371

Existem mil maneiras de preparar Neston. Invente a sua!
http://www.youtube.com/ExpressoExcel


ResponderCitar (Quote)
Compartilhar: